Bug 1048942 - Add option to automatically configure the Maven settings to use the public repository
Summary: Add option to automatically configure the Maven settings to use the public re...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER7
: EAP 6.3.0
Assignee: Thomas Hauser
QA Contact: Petr Kremensky
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-06 15:06 UTC by sgilda
Modified: 2017-10-10 00:20 UTC (History)
3 users (show)

(edit)
In this release of JBoss EAP 6 the Maven settings.xml configuration panel UI has been reconfigured.

The defaults have been made more intuitive and the panel now displays information in a clearer way.
Clone Of:
(edit)
Last Closed: 2014-06-28 15:53:51 UTC


Attachments (Terms of Use)

Description sgilda 2014-01-06 15:06:09 UTC
Description of problem:

It would be nice to add an option to automatically configure the Maven settings to use the public Maven repositories. The installer would need to add the following profiles:

    <!-- Configure the JBoss GA Maven repository -->
    <profile>
      <id>jboss-ga-repository</id>
      <repositories>
        <repository>
          <id>jboss-ga-repository</id>
          <url>http://maven.repository.redhat.com/techpreview/all</url>
          <releases>
            <enabled>true</enabled>
          </releases>
          <snapshots>
            <enabled>false</enabled>
          </snapshots>
        </repository>
      </repositories>
      <pluginRepositories>
        <pluginRepository>
          <id>jboss-ga-plugin-repository</id>
          <url>http://maven.repository.redhat.com/techpreview/all</url>
          <releases>
            <enabled>true</enabled>
          </releases>
          <snapshots>
            <enabled>false</enabled>
          </snapshots>
        </pluginRepository>
      </pluginRepositories>
    </profile>
    <!-- Configure the JBoss Early Access Maven repository -->
    <profile>
      <id>jboss-earlyaccess-repository</id>
      <repositories>
        <repository>
          <id>jboss-earlyaccess-repository</id>
          <url>http://maven.repository.redhat.com/earlyaccess/all/</url>
          <releases>
            <enabled>true</enabled>
          </releases>
          <snapshots>
            <enabled>false</enabled>
          </snapshots>
        </repository>
      </repositories>
      <pluginRepositories>
        <pluginRepository>
          <id>jboss-earlyaccess-plugin-repository</id>
          <url>http://maven.repository.redhat.com/earlyaccess/all/</url>
          <releases>
            <enabled>true</enabled>
          </releases>
          <snapshots>
            <enabled>false</enabled>
          </snapshots>
        </pluginRepository>
      </pluginRepositories>
    </profile>

And add them active to the active profiles:

    <activeProfile>jboss-ga-repository</activeProfile>
    <activeProfile>jboss-earlyaccess-repository</activeProfile>

NOTE: This bug is related to Bugzilla 1045543.
 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Thomas Hauser 2014-06-10 20:16:16 UTC
Not sure how I missed this. This is definitely fixed / included in the latest EAP installer versions. The maven settings file is now modified like the above, excluding the earlyaccess repos because it was determined that they are not required for quickstarts functionality.

Comment 2 sgilda 2014-06-10 20:42:31 UTC
Verified it works as expected.

Awesome job Tom. Works great! Thanks!


Note You need to log in before you can comment on or make changes to this bug.