Bug 1049072 - unable to add a rhs 2.1 GA (bigbend) node to a 3.2 cluster
Summary: unable to add a rhs 2.1 GA (bigbend) node to a 3.2 cluster
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: 2.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: RHGS 2.1.2
Assignee: Kanagaraj
QA Contact: Dustin Tsang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-06 23:17 UTC by Dustin Tsang
Modified: 2016-04-18 10:06 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-08 15:06:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dustin Tsang 2014-01-06 23:17:33 UTC
Description of problem:

Addition of a RHS node created from the RHSS-2.1-20130910.0-RHS-x86_64-DVD1.iso
to a 3.2 cluster created in rhsc-cb14, fails. 

2 events show up as failed when adding the node:

(1) Failed to install Host 10.14.16.202. Failed to execute stage 'Misc configuration': Command '/usr/share/vdsm/addNetwork' failed to execute.

(2) Host 10.14.16.202 installation failed. Command returned failure code 1 during SSH session 'root@10.14.16.202
excerpt from vdsm.log: SSH error running command root@10.14.16.202:'umask 0077; MYTMP="$(mktemp -t ovirt-XXXXXXXXXX)"; trap "chmod -R u+rwX \"${MYTMP}\" > /dev/null 2>&1; rm -fr \"${MYTMP}\" > /dev/null 2>&1" 0; rm -fr "${MYTMP}" && mkdir "${MYTMP}" && tar --warning=no-timestamp -C "${MYTMP}" -x &&  "${MYTMP}"/setup DIALOG/dialect=str:machine DIALOG/customization=bool:True': java.io.IOException: Command returned failure code 1 during SSH session 'root@10.14.16.202' 


Version-Release number of selected component (if applicable):
rhsc-cb14


How reproducible:


Steps to Reproduce:
1. create a fresh rhs instance from the 2.1 GA release of RHS, RHSS-2.1-20130910.0-RHS-x86_64-DVD1.iso
2. In rhsc, create 3.2 cluster
3. add the host to the cluster created

Actual results:
failures indicated in description


Expected results:
host is successfully added to cluster


Additional info:

Comment 1 Dustin Tsang 2014-01-06 23:23:55 UTC
logs attached here: http://rhsqe-repo.lab.eng.blr.redhat.com/dustin/1049072/

Comment 3 Kanagaraj 2014-01-08 06:38:39 UTC
I could not reproduce this issue after doing the following steps

1. New RHS node from ISO - RHSS-2.1-20130910.0-RHS-x86_64-DVD1.iso
2. Create cluster 'c1' with 3.2 compatibility version
3. Add the above node to cluster c1

After the above steps, host installation went through successfully and it came to UP status.

Dustin, 
please let me know if you have done any extra steps.

Comment 4 Dustin Tsang 2014-01-08 14:46:02 UTC
Hi Kanagaraj,

Those are the same, exact steps I followed. However, I'm unable to successfully add the node. I have also recreated a node using the iso and got the same results.

The rhsc instance I'm using is @ 10.14.16.158. The issue can be consistently reproduced from there.

Comment 5 Dustin Tsang 2014-01-08 15:06:19 UTC
After some more digging. I believe there may have been some networking issue with my node. I'm able to add the node successfully now.


Note You need to log in before you can comment on or make changes to this bug.