Bug 1049108 - qemu-kvm do not check media while '-drive' only specified 'serial' with '-M q35'
Summary: qemu-kvm do not check media while '-drive' only specified 'serial' with '-M q35'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Marcel Apfelbaum
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1227278
TreeView+ depends on / blocked
 
Reported: 2014-01-07 03:11 UTC by Xu Han
Modified: 2019-02-07 13:53 UTC (History)
9 users (show)

Fixed In Version: qemu-kvm-rhev-2.3.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:13:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Xu Han 2014-01-07 03:11:28 UTC
Description of problem:
qemu-kvm do not check media while '-drive' only specified 'serial' with '-M q35'
# /usr/libexec/qemu-kvm -M q35 -drive serial=dsfs
VNC server running on `::1:5900'

With '-M pc' would not hit this issue.
# /usr/libexec/qemu-kvm -M pc -drive serial=dsfs
qemu-kvm: Device needs media, but drive is empty
qemu-kvm: Device initialization failed.
qemu-kvm: Initialization of device ide-hd failed

Version-Release number of selected component (if applicable):
qemu-kvm-1.5.3-31.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. # /usr/libexec/qemu-kvm -M q35 -drive serial=dsfs
or # /usr/libexec/qemu-kvm -M q35 -drive if=ide

Actual results:
qemu-kvm do not check whether specified media.

Expected results:
Should check media and give error messages.

Additional info:

Comment 5 Marcel Apfelbaum 2015-05-05 15:08:29 UTC
Working on QEMU 2.3.

Comment 7 Jun Li 2015-06-25 06:53:15 UTC
Verify:

Version of components:
qemu-kvm-rhev-2.3.0-4.el7.x86_64


# /usr/libexec/qemu-kvm -M q35 -drive serial=dsfs
qemu-kvm: Device needs media, but drive is empty
qemu-kvm: Initialization of device ide-hd failed: Device initialization failed.

# /usr/libexec/qemu-kvm -M q35 -drive if=ide
qemu-kvm: Device needs media, but drive is empty
qemu-kvm: Initialization of device ide-hd failed: Device initialization failed.


As above show, this bz have been verified.

Double-checked with Xu Han, so set this bz as verified. 

Any issue, free to correct me. Thx.

Comment 10 errata-xmlrpc 2015-12-04 16:13:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.