Bug 1049192 - Cannot create guest on remote rhel6 host using F20 virt-manager
Summary: Cannot create guest on remote rhel6 host using F20 virt-manager
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 20
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-07 07:57 UTC by tingting zheng
Modified: 2014-01-17 23:50 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-17 23:50:21 UTC
Type: Bug


Attachments (Terms of Use)

Description tingting zheng 2014-01-07 07:57:19 UTC
Description of problem:
From a Fedora 20 desktop, run virt-manager.  Connect over ssh to a server running RHEL6.  Try to create a guest, error shows:
Unable to complete install: 'Cannot check QEMU binary /usr/bin/qemu-kvm: No such file or directory'

Version-Release number of selected component (if applicable):
Fedora 20 version:
virt-manager-0.10.0-5.git1ffcc0cc.fc20.noarch
libvirt-1.1.3.1-2.fc20.x86_64

Remote rhel6 host:
libvirt-0.10.2-29.el6.1.x86_64

How reproducible:
100%

Steps to Reproduce:
1.On Fedora 20 desktop, run virt-manager.
2.File->Add connection,add a remote rhel6 host.
3.On the new connection,create a new guest.
4.Tried pxe or iso installation,after all the default configuration set,then creating guest fail with error:
Unable to complete install: 'Cannot check QEMU binary /usr/bin/qemu-kvm: No such file or directory'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 91, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 1959, in do_install
    guest.start_install(meter=meter)
  File "/usr/share/virt-manager/virtinst/guest.py", line 389, in start_install
    noboot)
  File "/usr/share/virt-manager/virtinst/guest.py", line 454, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 2897, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: Cannot check QEMU binary /usr/bin/qemu-kvm: No such file or directory

Actual results:
As description.

Expected results:
Guest can be installed successfully on remote rhel6 host using F20 desktop.

Additional info:

Comment 2 Giuseppe Scrivano 2014-01-08 16:29:28 UTC
I cannot reproduce it here, this is what I get in the definition XML for the new domain when I try to create it on a RHEL-6.5 from virt-manager running on Fedora 20:

  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
   ........
  </devices>


I have used this version of virt-manager:

virt-manager.noarch                 0.10.0-5.git1ffcc0cc.fc20           @fedora 

Could you please attach the output of "virt-manager --debug"?

Comment 3 tingting zheng 2014-01-10 05:39:48 UTC
(In reply to Giuseppe Scrivano from comment #2)
> I cannot reproduce it here, this is what I get in the definition XML for the
> new domain when I try to create it on a RHEL-6.5 from virt-manager running
> on Fedora 20:
> 
>   <devices>
>     <emulator>/usr/libexec/qemu-kvm</emulator>
>    ........
>   </devices>
> 
> 
> I have used this version of virt-manager:
> 
> virt-manager.noarch                 0.10.0-5.git1ffcc0cc.fc20          
> @fedora 
> 
> Could you please attach the output of "virt-manager --debug"?

I tried http and pxe installation,the first time it will show the error as description,however when I tried to use virt-manager --debug,no such error messages and guests can be created successfully.
Tried several times,I can not reproduce it right now,I will post the debug info once I reproduce it.

Comment 4 Cole Robinson 2014-01-17 23:50:21 UTC
Okay, closing for now then. Please reopen if you reproduce later


Note You need to log in before you can comment on or make changes to this bug.