Bug 1049200 - cannot create vn2vn instance via fcoeadm
Summary: cannot create vn2vn instance via fcoeadm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: fcoe-utils
Version: 7.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Chris Leech
QA Contact: xhe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1062567 1063932 1067873 1070921 1073810 1077078 1094654 1113511 1049170 1050845 1055830 1057960 1062801 1066200 1069502 1070517 1083244 1086308
TreeView+ depends on / blocked
 
Reported: 2014-01-07 08:22 UTC by Xiaowei Li
Modified: 2015-03-05 13:24 UTC (History)
2 users (show)

Fixed In Version: fcoe-utils-1.0.29-8.el7
Doc Type: Bug Fix
Doc Text:
Cause: The fcoeadm tool was not properly sending VN2VN create requests to fcoemon. Consequence: Requested VN2VN mode FCoE interfaces would actually be created as fabric mode. Fix: fcoeadm was fixed to pass the proper command to fcoemon Result: VN2VN interface creation with fcoeadm works as expected
Clone Of:
: 1331614 (view as bug list)
Environment:
Last Closed: 2015-03-05 13:24:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0560 normal SHIPPED_LIVE fcoe-utils bug fix and enhancement update 2015-03-05 16:44:28 UTC

Description Xiaowei Li 2014-01-07 08:22:09 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. # fcoeadm -c p2p2 -m vn2vn
fcoeadm: Internal error
Try 'fcoeadm --help' for more information.
# echo $?
6
this is another issue. don't care it.
# fcoeadm -i
    Description:      82599EB 10-Gigabit SFI/SFP+ Network Connection
    Revision:         01
    Manufacturer:     Intel Corporation
    Serial Number:    90E2BA5663D8
    Driver:           ixgbe 3.15.1-k
    Number of Ports:  1

        Symbolic Name:     fcoe v0.1 over p2p2
        OS Device Name:    host5
        Node Name:         0x100090E2BA5663DB
        Port Name:         0x200090E2BA5663DB
        FabricName:        0x0000000000000000
        Speed:             10 Gbit
        Supported Speed:   1 Gbit, 10 Gbit
        MaxFrameSize:      2112
        FC-ID (Port ID):   0xFFFFFFFF
        State:             Offline
2. cat /sys/bus/fcoe/devices/ctlr_1/mode
Fabric
3.

Actual results:
the port state is offline and the mode is Fabric.

Expected results:
the port state is online and the mode is vn2vn

Additional info:

workaround: echo vn2vn > /sys/bus/fcoe/devices/ctlr_1/mode

#cd /sys/bus/fcoe/devices/ctlr_1/
# cat enabled 
1
# cat mode 
Fabric
# echo vn2vn > mode 
-bash: echo: write error: Device or resource busy
# echo 0 > enabled 
# echo vn2vn > mode 
# echo 1 > enabled 
# fcoeadm -i
    Description:      82599EB 10-Gigabit SFI/SFP+ Network Connection
    Revision:         01
    Manufacturer:     Intel Corporation
    Serial Number:    90E2BA5663D8
    Driver:           ixgbe 3.15.1-k
    Number of Ports:  1

        Symbolic Name:     fcoe v0.1 over p2p2
        OS Device Name:    host5
        Node Name:         0x100090E2BA5663DB
        Port Name:         0x200090E2BA5663DB
        FabricName:        0x0000000000000000
        Speed:             10 Gbit
        Supported Speed:   1 Gbit, 10 Gbit
        MaxFrameSize:      2112
        FC-ID (Port ID):   0x0063DB
        State:             Online

Comment 1 Xiaowei Li 2014-01-07 08:23:06 UTC
fcoe-utils-1.0.29-2.el7.x86_64

Comment 3 Petr Šabata 2014-01-14 13:54:51 UTC
Just like in bug #1046226, could you retry with SELinux disabled and post any AVC messages you get, if applicable?

Comment 4 Xiaowei Li 2014-01-21 03:25:18 UTC
retry with SELinux disabled. and still get the same issue. It seems like the option "-m vn2vn" does not work. it always use the Fabric mode to create the FCoE instance.

[root@hp-dl388g8-23 ~]# setenforce 0
[root@hp-dl388g8-23 ~]# fcoeadm -m vn2vn -c p2p1
[root@hp-dl388g8-23 ~]# fcoeadm -i
    Description:      82599EB 10-Gigabit SFI/SFP+ Network Connection
    Revision:         01
    Manufacturer:     Intel Corporation
    Serial Number:    90E2BA5661D8
    Driver:           ixgbe 3.15.1-k
    Number of Ports:  1

        Symbolic Name:     fcoe v0.1 over p2p1
        OS Device Name:    host3
        Node Name:         0x100090E2BA5661DA
        Port Name:         0x200090E2BA5661DA
        FabricName:        0x0000000000000000
        Speed:             Unknown
        Supported Speed:   1 Gbit, 10 Gbit
        MaxFrameSize:      2112
        FC-ID (Port ID):   0xFFFFFFFF
        State:             Linkdown
[root@hp-dl388g8-23 ~]# cat /sys/bus/fcoe/devices/ctlr_0/mode 
Fabric

Comment 7 Xiaowei Li 2014-02-26 09:49:31 UTC
set it to blocker since vn2vn is the rhel 7.0 fcoe feature. we should support it via the fcoeadm.

Comment 9 Petr Šabata 2014-03-06 12:47:49 UTC
(In reply to Xiaowei Li from comment #7)
> set it to blocker since vn2vn is the rhel 7.0 fcoe feature. we should
> support it via the fcoeadm.

As there is a workaround, I don't believe this meets the blocker criteria.

Comment 10 Xiaowei Li 2014-03-11 04:10:25 UTC
(In reply to Petr Šabata from comment #9)
> (In reply to Xiaowei Li from comment #7)
> > set it to blocker since vn2vn is the rhel 7.0 fcoe feature. we should
> > support it via the fcoeadm.
> 
> As there is a workaround, I don't believe this meets the blocker criteria.

okay for me to remove the blocker keyword. but let's keep the urgent priority so that we can fix it asap.

Comment 11 Xiaowei Li 2014-03-11 04:11:25 UTC
(In reply to Xiaowei Li from comment #10)
> (In reply to Petr Šabata from comment #9)
> > (In reply to Xiaowei Li from comment #7)
> > > set it to blocker since vn2vn is the rhel 7.0 fcoe feature. we should
> > > support it via the fcoeadm.
> > 
> > As there is a workaround, I don't believe this meets the blocker criteria.
> 
> okay for me to remove the blocker keyword. but let's keep the urgent
> priority so that we can fix it asap.

also if cannot fix it in 7.0 we should document this known issue.

Comment 17 xhe@redhat.com 2014-12-12 06:44:45 UTC
It's fixed. Move to VERIFIED.

---------- Verification Steps ---------------
# hostname
storageqe-51.rhts.eng.nay.redhat.com

# uname -a
Linux storageqe-51.rhts.eng.nay.redhat.com 3.10.0-215.el7.x86_64 #1 SMP Mon Dec 8 10:19:09 EST 2014 x86_64 x86_64 x86_64 GNU/Linux

# rpm -qa|grep fcoe-utils
fcoe-utils-1.0.29-8.el7.x86_64

# fcoeadm -c p1p1 -m vn2vn
# fcoeadm -i
    Description:      82599ES 10-Gigabit SFI/SFP+ Network Connection
    Revision:         01
    Manufacturer:     Intel Corporation
    Serial Number:    001B213FA1B4
    Driver:           ixgbe 3.19.1-k
    Number of Ports:  1

        Symbolic Name:     fcoe v0.1 over p1p1
        OS Device Name:    host11
        Node Name:         0x1000001B213FA1B6
        Port Name:         0x2000001B213FA1B6
        FabricName:        0x0000000000000000
        Speed:             10 Gbit
        Supported Speed:   1 Gbit, 10 Gbit
        MaxFrameSize:      2112
        FC-ID (Port ID):   0x00A1B6
        State:             Online

# cat /sys/bus/fcoe/devices/ctlr_4/mode 
VN2VN


Thanks,
Nancy

Comment 20 errata-xmlrpc 2015-03-05 13:24:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0560.html


Note You need to log in before you can comment on or make changes to this bug.