Bug 1049338 - listen address attribute ignored by peer-to-peer migration
listen address attribute ignored by peer-to-peer migration
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ján Tomko
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-07 07:50 EST by Ján Tomko
Modified: 2014-06-17 21:02 EDT (History)
7 users (show)

See Also:
Fixed In Version: libvirt-1.1.1-18.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:21:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ján Tomko 2014-01-07 07:50:50 EST
Description of problem:
The listen address attribute is ignored by peer-to-peer migration.

Version-Release number of selected component (if applicable):
libvirt-1.1.1-16.el7

How reproducible:
Certainly.

Steps to Reproduce:
1. Do a peer-to-peer migration with a listen address that the destination can't use:
virsh migrate --live --p2p --listen-address 1.2.3.4 cake qemu+ssh://dest/system

Actual results:
Migration succeeds.

Expected results:
Migration fails because of the listen address:
qemu-kvm: -incoming tcp:1.2.3.4:49152: Failed to bind socket: Cannot assign requested address

Additional info:
Upstream patch: https://www.redhat.com/archives/libvir-list/2014-January/msg00229.html
Comment 1 Ján Tomko 2014-01-07 08:09:34 EST
Fixed upstream by:
commit bcd0ac47d8d7ec6230fe23f4b99891339e9d137d
Author:     Minoru Usui <usui@mxm.nes.nec.co.jp>
CommitDate: 2014-01-07 13:59:50 +0100

    Fix argument order of qemuMigrationPerformJob().
git describe: v1.2.0-225-gbcd0ac4

Downstream patch posted:
http://post-office.corp.redhat.com/archives/rhvirt-patches/2014-January/msg00040.html
Comment 3 zhoujunqin 2014-01-23 22:04:15 EST
I can reproduce this bug with the reproducer in bug destription with libvirt-1.1.1-16.el7, and I could get the expect error after i update the libvirt to the  libvirt-1.1.1-19.el7,so this bug can be marked verified.

Reproduce steps
1. start a guest for migration
2.do a peer-to-peer migration with a listen address that the destination can't use:
# virsh migrate --live --p2p --listen-address 1.2.3.4 raw qemu+ssh://$ip/system
Migration succeeds.

Verify steps
1.start a guest for migration
# virsh list 
 Id    Name                           State
----------------------------------------------------
 6     raw                            running
2.do a peer-to-peer migration with a listen address that the destination can't use:
# virsh migrate --live --p2p --listen-address 1.2.3.4 raw qemu+ssh://$ip/system
error: internal error: early end of file from monitor: possible problem:
qemu-kvm: -incoming tcp:1.2.3.4:49152: Failed to bind socket: Cannot assign requested address
3.do a peer-to-peer migration with a listen address that the destination can use:
# virsh migrate --live --p2p --listen-address $ip  raw qemu+ssh://$ip/system
Migration succeeds.
4.do a peer-to-peer migration without listen address
# virsh migrate --live --p2p raw  qemu+ssh://$ip/system
Migration succeeds.
Comment 7 Ludek Smid 2014-06-13 09:21:33 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.