Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1049382 - EMC: fails to create volume from Glance image
Summary: EMC: fails to create volume from Glance image
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: RDO
Classification: Community
Component: openstack-cinder
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Dafna Ron
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-07 13:56 UTC by Giulio Fidente
Modified: 2016-04-26 18:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-20 15:49:01 UTC


Attachments (Terms of Use)
cinder_emc_volume_from_image_trace.txt (3.87 KB, text/plain)
2014-01-07 13:56 UTC, Giulio Fidente
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1266834 0 None None None Never

Description Giulio Fidente 2014-01-07 13:56:53 UTC
Created attachment 846681 [details]
cinder_emc_volume_from_image_trace.txt

Description of problem:
When Cinder is configured to use the EMC driver(*), creation of volumes from images fails. Attached to the bug is the trace appearing in volume.log

* cinder.volume.drivers.emc.emc_smis_iscsi.EMCSMISISCSIDriver


Version-Release number of selected component (if applicable):
openstack-cinder-2014.1-0.2.b1.el6.noarch


Steps to Reproduce:
1. configure Cinder with the EMC driver
2. try to create a volume using the "--image-id" option

Comment 1 Giulio Fidente 2014-01-07 15:42:27 UTC
I attempted to troubleshoot this and "fixed" the initial issue by installing the iscsi-initiator-utils package.

Yet, the operation is still failing with a wierd error from the CMI (SMI-S):

  2014-01-07 16:21:59.463 1213 TRACE cinder.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/cinder/volume/drivers/emc/emc_smis_common.py", line 1380, in find_device_number
  2014-01-07 16:21:59.463 1213 TRACE cinder.openstack.common.rpc.amqp     ResultClass='CIM_ProtocolControllerForUnit')
  2014-01-07 16:21:59.463 1213 TRACE cinder.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/pywbem/cim_operations.py", line 775, in ReferenceNames
  2014-01-07 16:21:59.463 1213 TRACE cinder.openstack.common.rpc.amqp     **params)
  2014-01-07 16:21:59.463 1213 TRACE cinder.openstack.common.rpc.amqp   File "/usr/lib/python2.6/site-packages/pywbem/cim_operations.py", line 219, in imethodcall
  2014-01-07 16:21:59.463 1213 TRACE cinder.openstack.common.rpc.amqp     raise CIMError(code, tt[1]['DESCRIPTION'])
  2014-01-07 16:21:59.463 1213 TRACE cinder.openstack.common.rpc.amqp CIMError: (1, u'A general error occurred that is not covered by a more specific error code. (com.emc.cmp.osls.se.osl.Maskin
g.StorMaskGroupShow():138 C:ERROR_CLASS_SOFTWARE F:ERROR_FAMILY_FAILED R:1200019 C:ERROR_CLASS_SOFTWARE F:ERROR_FAMILY_FAILED R:1200019 The internal database is in an inconsistent state, and 
must be fully synchronized before performing this operation.)')

While at first look that looks like an issue with the EMC CIM software itself, the software is instead working fine when Cinder attempts to create a new empty volume.

Comment 2 Lars Kellogg-Stedman 2015-03-20 15:49:01 UTC
Upstream bug has been marked invalid, and Giulio reported upstream that he was no longer experiencing this problem.


Note You need to log in before you can comment on or make changes to this bug.