Bug 1049486 - [spice-xpi] no info about proxy in spice-xpi.log even it virtually use proxy
Summary: [spice-xpi] no info about proxy in spice-xpi.log even it virtually use proxy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-xpi
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Christophe Fergeau
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks: 1131442
TreeView+ depends on / blocked
 
Reported: 2014-01-07 15:49 UTC by Jiri Belka
Modified: 2015-07-22 07:28 UTC (History)
7 users (show)

Fixed In Version: spice-xpi-2.7-26.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, certain spice-xpi properties were not recorded in the spice-xpi.log file. These properties were only displayed in the /var/log/messages file. With this update, spice-xpi has been modified to properly log reading or setting the "smartcard", "color-depth", "disable-effects", and "proxy" properties of the spice-xpi browser plug-in. As a result, these events are now visible in spice-xpi.log.
Clone Of:
: 1131442 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:28:22 UTC


Attachments (Terms of Use)
Add a log when setting/getting proxy property (2.00 KB, patch)
2014-01-08 10:53 UTC, Christophe Fergeau
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1393 normal SHIPPED_LIVE spice-xpi bug fix update 2015-07-20 18:07:32 UTC

Description Jiri Belka 2014-01-07 15:49:36 UTC
Description of problem:
It was discovered that spice-xpi uses proxy even RHEVM had proxy option unchecked in Console options.

During troubleshooting there was no info about proxy in spice-xpi.log but in /var/log/messages SPICE_PROXY appeared (reality).

See BZ1049475 for logs...

Version-Release number of selected component (if applicable):
spice-xpi-2.7-24.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. RHEVM: define proxy, restart  engine, open console while proxy is unchecked
2. compare spice-xpi.log with /var/log/messages for proxy info
3.

Actual results:
inconsistency

Expected results:
if in fact proxy is used it should be visible in spice-xpi.log

Additional info:

Comment 2 Christophe Fergeau 2014-01-08 10:53:51 UTC
Created attachment 847080 [details]
Add a log when setting/getting proxy property

This patch should fixe this logging issue. Scratch build at http://brewweb.devel.redhat.com/brew/taskinfo?taskID=6824710

Comment 3 Christophe Fergeau 2014-01-08 11:01:20 UTC
Note that in rhel 7, there will be no spice-xpi.log. remote-viewer will log debug messages (enable with G_MESSAGES_DEBUG=all) with the controller properties it received.

Comment 8 errata-xmlrpc 2015-07-22 07:28:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1393.html


Note You need to log in before you can comment on or make changes to this bug.