Bug 10495 - syntax error in Xsession
syntax error in Xsession
Status: CLOSED DUPLICATE of bug 10322
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-31 16:09 EST by mw
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-31 17:00:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mw 2000-03-31 16:09:46 EST
In /etc/X11/xdm/Xsession the line

if [ -z $XKB_IN_USE -a ! -L /etc/X11/X ]; then

causes an error if $XKB_IN_USE="".  Correctly:

if [ -z "$XKB_IN_USE" -a ! -L /etc/X11/X ]; then

Despite this correction, I cannot make my BackSpace delte backward---which
was working perfectly before my upgarde to 6.2.  Perhaps there is something
else in this file that is not correct?

Thx

Mate
Comment 1 mw 2000-03-31 16:19:59 EST
Some more problems I see:

# xkb and xmodmap don't play nice together
if [ -z $XKB_IN_USE ]; then

again, $XKB_IN_USE not quoted.  Also, I do not see `sysxkbmap', `userxkbmap'
defined anywhere in the file.

Mate
---
Mate Wierdl | Dept. of Math. Sciences | University of Memphis
Comment 2 mw 2000-03-31 17:00:59 EST
*** This bug has been marked as a duplicate of 10322 ***

Note You need to log in before you can comment on or make changes to this bug.