Bug 1049580 - dependency issues in nodems-mongodb and nodejs-ws on epel6
Summary: dependency issues in nodems-mongodb and nodejs-ws on epel6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: npm
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Troy Dawson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-07 19:36 UTC by Tuomo Soini
Modified: 2014-03-12 00:01 UTC (History)
3 users (show)

Fixed In Version: nodejs-ws-0.4.25-8.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-12 00:01:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Tuomo Soini 2014-01-07 19:36:16 UTC
Description of problem:

package: nodejs-mongodb-1.3.19-2.el6.noarch from epel-testing
  unresolved deps: 
     npm(bson) = 0:0.2.2
package: nodejs-ws-0.4.25-6.el6.x86_64 from epel-testing
  unresolved deps: 
     npm(express) < 0:3.1
     npm(express) < 0:3
     nodejs(engine) < 0:0.7

Comment 1 Troy Dawson 2014-01-09 00:02:20 UTC
nodejs-mongodb problem fixed in nodejs-mongodb-1.3.19-3.el6

Comment 2 Tuomo Soini 2014-01-22 08:28:56 UTC
Hey, nodejs-ws problem is still there.

Comment 3 Troy Dawson 2014-01-22 15:00:00 UTC
Yep, keep running out of time for that one.
nodejs-ws-0.4.25-6.el6 one is strange because those dependencies don't show up in any of the Fedora builds.  Just the el6 version.

Comment 4 Troy Dawson 2014-01-22 16:54:50 UTC
nodejs-ws is totally bizarre because those dependencies aren't in the json.
It must be a bug in the dependency script.  I haven't verified, but I believe it is pulling in the dependencies from all the packages it needed during it's build.

Comment 5 Troy Dawson 2014-01-22 20:57:00 UTC
I've tracked it down that it's pulling in the dependencies from the examples.
Since Fedora isn't doing that, only RHEL, I don't think that is the expected behaviour.

Comment 6 Fedora Update System 2014-01-24 16:00:14 UTC
nodejs-ws-0.4.25-7.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nodejs-ws-0.4.25-7.el6

Comment 7 Troy Dawson 2014-01-24 16:03:20 UTC
Fixed nodejs-ws by removing it's example directory.
I have also created a bugzilla for the problem.
https://bugzilla.redhat.com/show_bug.cgi?id=1057703

Comment 8 Fedora Update System 2014-01-25 05:08:40 UTC
Package nodejs-ws-0.4.25-7.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing nodejs-ws-0.4.25-7.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0316/nodejs-ws-0.4.25-7.el6
then log in and leave karma (feedback).

Comment 9 T.C. Hollingsworth 2014-01-27 20:47:06 UTC
I filed a buildroot override for the fixed nodejs-packaging if you'd like to restore the examples.

Comment 10 Fedora Update System 2014-02-04 19:48:43 UTC
nodejs-ws-0.4.25-8.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nodejs-ws-0.4.25-8.el6

Comment 11 Fedora Update System 2014-03-12 00:01:17 UTC
nodejs-ws-0.4.25-8.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.