Bug 1049622 - Rollback of setup seems to remove several configuration files when upgrade is ran again setup will prompt for hostname and other data
Summary: Rollback of setup seems to remove several configuration files when upgrade is...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 3.3.0
Assignee: Sandro Bonazzola
QA Contact: Tareq Alayan
URL:
Whiteboard: integration
Depends On:
Blocks: 902971 1051001 rhev3.3ga
TreeView+ depends on / blocked
 
Reported: 2014-01-07 21:07 UTC by Tomas Dosek
Modified: 2014-03-20 14:18 UTC (History)
16 users (show)

Fixed In Version: is32.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Failed upgrade logs (1.98 MB, text/x-log)
2014-01-07 21:07 UTC, Tomas Dosek
no flags Details
engine + server + setup logs (102.29 KB, application/x-compressed-tar)
2014-01-09 13:53 UTC, Barak Dagan
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 667073 None None None Never
oVirt gerrit 23071 None None None Never
oVirt gerrit 23092 None None None Never

Description Tomas Dosek 2014-01-07 21:07:26 UTC
Created attachment 846837 [details]
Failed upgrade logs

Description of problem:
Rollback of setup seems to remove several configuration files when upgrade is ran again setup will prompt for hostname and other data like NFS ISO domain in RHEV-M, firewall, etc.

Also all relevant messages include setup instead of upgrade which makes users quite worried

Version-Release number of selected component (if applicable):
is29

How reproducible:
100 %

Steps to Reproduce:
1. Have working 3.2.5 setup
2. Move /etc/pki/ovirt-engine/cacert.conf to move /etc/pki/ovirt-engine/cacert.conf.bak
3. Perform upgrade (it will fail and rollback)
4. Move the file back
5. Perform upgrade again

Actual results:
Upgrade asks about all setup details like RHEV-M was never installed

Expected results:
Upgrade should not ask for these details.

Additional info:
Attaching logs of the failed upgrade

Comment 1 Sandro Bonazzola 2014-01-08 09:42:48 UTC
I can't reproduce this following provided steps.
Just renaming cacert.conf is not enough, I think that you should have been using also non standard ports for apache, causing updateAIA to be called in legacy module.

Comment 2 Sandro Bonazzola 2014-01-08 10:59:04 UTC
Reproduced upgrading from 3.1 -> 3.2 -> 3.3 using JBoss on port 8700 and 8701.
After rollback engine-setup questions differs from clean upgrade only for:

 - Host fully qualified DNS name of this server

remaining questions:
 - Do you want Setup to configure the firewall?
 - Configure an NFS share on this server to be used as an ISO Domain?
 - Configure WebSocket Proxy on this machine?
 - Would you like transactions from the Red Hat Access Plugin sent from the RHEV Manager to be brokered through a proxy server?

are there because they're introducing support for new features or features not enabled on existing setup.

Looking on why Host fully qualified DNS name of this server is asked after rollback but it doesn't seem to be a blocker IMHO.

Comment 3 Yedidyah Bar David 2014-01-08 11:08:15 UTC
(In reply to Sandro Bonazzola from comment #2)
> Reproduced upgrading from 3.1 -> 3.2 -> 3.3 using JBoss on port 8700 and
> 8701.
> After rollback engine-setup questions differs from clean upgrade only for:
> 
>  - Host fully qualified DNS name of this server
> 
> remaining questions:
>  - Do you want Setup to configure the firewall?
>  - Configure an NFS share on this server to be used as an ISO Domain?
>  - Configure WebSocket Proxy on this machine?
>  - Would you like transactions from the Red Hat Access Plugin sent from the
> RHEV Manager to be brokered through a proxy server?
> 
> are there because they're introducing support for new features or features
> not enabled on existing setup.
> 
> Looking on why Host fully qualified DNS name of this server is asked after
> rollback but it doesn't seem to be a blocker IMHO.

I recommend that you backup /etc before the upgrade attempt and diff -ubr to see what changed. You might find other changes that are not obvious when re-running setup but are still significant.

Comment 4 Sandro Bonazzola 2014-01-08 11:09:36 UTC
On upgrade FQDN is read from /etc/sysconfig/ovirt-engine on customization stage.

On failure, after rollback, /etc/sysconfig/ovirt-engine is empty and previous version is in /etc/sysconfig/ovirt-engine.rpmsave

We're missing /etc/sysconfig/ovirt-engine rollback.

Comment 5 Barak Dagan 2014-01-09 13:53:22 UTC
Created attachment 847658 [details]
engine + server + setup logs

Reproduced by entering non valid db upgarde script
(/usr/share/ovirt-engine/dbscripts/upgrade/03_02_0470_test_me.sql which contains some randomized / meaningless strings) - system was configured with remote db.

I was asked the following questions during the 2nd upgarde try:
Host fully qualified DNS name of this server
Do you want Setup to configure the firewall
Where is the database located?

When remote option is selected - I'm getting the install message:

ATTENTION
         
          Manual action required.
          Please create database for ovirt-engine use. Use the following commands as an example:
.....


while my DB has different attribute, as it was created by previous version convention.


IMHO, this one is an urgent blocker - upgrade failure, put rhevm in non working, non upgradable state.

Comment 6 Tareq Alayan 2014-01-16 09:09:15 UTC
verified on 
rhevm-setup-3.3.0-0.45.el6ev.noarch
rhevm-3.3.0-0.45.el6ev.noarch


- Installed 3.2.5
- While installation i answered not to override httpd configuration
- mv /etc/pki/ovirt-engine/cacert.conf /etc/pki/ovirt-engine/cacert.conf.bak
- yum update rhevm-setup to 3.3
- rhevm-setup failed and rolled back to 3.2.5
-  mv /etc/pki/ovirt-engine/cacert.conf.bak /etc/pki/ovirt-engine/cacert.conf
- ran rhevm-setup again - it succeeded and did not ask too many questions

Comment 7 Itamar Heim 2014-01-21 22:28:43 UTC
Closing - RHEV 3.3 Released

Comment 8 Itamar Heim 2014-01-21 22:28:44 UTC
Closing - RHEV 3.3 Released

Comment 9 Itamar Heim 2014-01-21 22:31:42 UTC
Closing - RHEV 3.3 Released


Note You need to log in before you can comment on or make changes to this bug.