Bug 1049643 - Using the project search field breaks the drop down main menu
Using the project search field breaks the drop down main menu
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
development
Unspecified Unspecified
high Severity high
: ---
: 3.3
Assigned To: Alex Eng
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-07 17:59 EST by Damian Jansen
Modified: 2014-03-20 01:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.3.0-SNAPSHOT (20140115-0828)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-20 01:47:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2014-01-07 17:59:25 EST
Description of problem:
If the Search Zanata For... field is used, the user drop-down menu (Settings, Logout etc) will stop working

Version-Release number of selected component (if applicable):
dev

How reproducible:
Easy always

Steps to Reproduce:
1. Sign in
2. Enter "about" in the Search box and press enter
3. Click the drop down menu

Actual results:
Nothing happens, url changes to url#nav-user

Expected results:
Drop down menu drops down

Additional info:
High priority as this makes it difficult for a user to log out
Comment 1 Luke Brooker 2014-01-07 18:34:22 EST
Seems this is not just related to search but any pages using the old template, which is most. It looks like the js has a error with the new tooltip component on these pages. I will talk to Alex about it.
Comment 2 Alex Eng 2014-01-13 16:40:18 EST
Its caused of order of javascript import.
See https://github.com/zanata/zanata-server/pull/335
Comment 3 Damian Jansen 2014-01-14 19:21:51 EST
Verified at 45ca2ddf57112f332735c61270e3693251e6a114
Comment 4 Sean Flanigan 2014-03-20 01:47:35 EDT
Closing VERIFIED bugs for Zanata server 3.3.2.

Note You need to log in before you can comment on or make changes to this bug.