Bug 1049671 - DNF does not install local downloaded .rpm into system.
Summary: DNF does not install local downloaded .rpm into system.
Keywords:
Status: CLOSED DUPLICATE of bug 1056400
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Radek Holy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1048577 1051612 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-08 01:40 UTC by Álvaro Castillo
Modified: 2015-10-06 02:14 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-24 08:49:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Álvaro Castillo 2014-01-08 01:40:36 UTC
Description of problem:

DNF cannot install .RPMs downloaded. I have to use yum /home/$USER/Downloads/Acetea.rpm instead use dnf /home/$USER/Downloads/Acetea.rpm because cannot install it. DNF searches into RPM database but not install packages that yum does.


Version-Release number of selected component (if applicable):
dnf-0.4.10-1.fc20.noarch

How reproducible:


Steps to Reproduce:
1. Download any .rpm package
2. Run dnf /folder_where_you_downloaded_package/nn.rpm
3. Try next time with yum, you will see can install package.

Actual results:


Expected results:


Additional info:
- Full system updated
- New installation (does not upgraded over fedup)

Comment 1 Ales Kozumplik 2014-01-08 07:57:20 UTC
Reproduced. Can you please take a look Radek?

Comment 2 Adam Williamson 2014-01-10 22:44:59 UTC
Confirmed here too.

Comment 3 Adam Williamson 2014-01-10 22:45:36 UTC
*** Bug 1051612 has been marked as a duplicate of this bug. ***

Comment 4 Parag Nemade 2014-01-13 09:38:57 UTC
I too found this bug in Fedora 20 with dnf-0.4.10-1.fc20 installed. It just said
Error: Nothing to do.

Comment 5 Petr Spacek 2014-01-13 11:18:16 UTC
I have encountered the same problem with dnf-0.4.11-1.fc20.noarch.

Isn't this a duplicate of #1048577?

Comment 6 Ales Kozumplik 2014-01-13 13:24:47 UTC
*** Bug 1048577 has been marked as a duplicate of this bug. ***

Comment 7 Ales Kozumplik 2014-01-24 08:49:25 UTC
turns out this is the same issue as bug 1056400. We are already fixing that so closing this one.

*** This bug has been marked as a duplicate of bug 1056400 ***


Note You need to log in before you can comment on or make changes to this bug.