Bug 104974 - Has to keep adjusting the Philips 109B Monitor on Nvidia 16MB whenever switching to Windows
Has to keep adjusting the Philips 109B Monitor on Nvidia 16MB whenever switch...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-23 23:01 EDT by Giorel
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 01:47:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 log file (60.66 KB, text/plain)
2003-09-23 23:04 EDT, Giorel
no flags Details

  None (edit)
Description Giorel 2003-09-23 23:01:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030716

Description of problem:
When starting on text console, display is centered.  However when launching X
the display is shifted about an inch right.  Thus need to adjust the monitor.

However upon reboot into Windows 2000 (dual-boot), the display is now shifted an
inch left.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot into linux.  Start X.  Adjust the monitor
2.reboot into Windows.
    

Actual Results:  Display goes right booting into X
It goes left booting into Windows

Expected Results:  The display should not shift at all

Additional info:

If its just text mode and Windows you do not have to adjust the monitor, only if
you start X

I open bug on behalf of customer.  I suggest in the meantime download Nvidias
driver if that will help.
Comment 1 Giorel 2003-09-23 23:04:27 EDT
Created attachment 94669 [details]
XFree86 log file

Hope this will help
Comment 2 Giorel 2003-09-23 23:11:36 EDT
Also, when going back from X to console mode the display is shifted left so have
to use the horizontal adjust again.  Just to let you know, since this instance
is separate from Windows.
Comment 3 Mike A. Harris 2003-09-24 01:47:31 EDT
XFree86 uses only VESA GTF (and it's predecessor) built in video modelines,
which are the definitive VESA standard for video mode timings.  These built
in modelines are created specifically to prevent the types of problem being
reported here.  ;o)

The customer's problem is caused because their config file (which is not
attached) is configured to override XFree86's built in video modes with
a huge plethora of video modes, including ones that we very definitely do
not support.  Custom video modes allow the user to create their own video
mode resolutions at different refresh rates, including those that do not
come with our default server.  It also allows the user to tweak the video
timings and move the picture to the left, right, up, down and to resize
the visible display both horizontally and vertically as well.

When a user overrides the built in video modes using custom defaults,
they are no longer using modes supported by Red Hat.  In the simplest cases,
they may end up with a distorted display, screen flickering, shimmering
display or edges of the display, picture wraparound, picture off screen
(as in this report), or any number of other problems.  In the worst case,
the user can physically and permanently damage or destroy their monitor
or LCD panel and/or their video hardware, in particular older hardware
which does not protect against out of range signals.

Basically - end users should not be editing video modes unless they know
what they're doing and can accept the concequences and solve any problems
that arise themselves.

In order to resolve this problem, the user should delete their existing 
X config files, or move them out of the way, and then run:

redhat-config-xfree86 --reconfig

The resulting configuration should work properly and their display should
be correctly centered on the screen.  If they absolutely have a requirement
or preference to customize the video modes, either just for personal
preference, higher refresh rates than what are supplied, or for video games
such as those requiring modes less than 640x480 (as seen in the attached
X server log file), they are of course free to do so, however Red Hat does
not provide support for problems encountered using customized modelines,
and any support requests for help should be made via the XFree86 public
mailing lists.

If this problem recurs while using a redhat-config-xfree86 supplied config
file also, which I highly doubt will be the case <grin>, then it would be
theoretically possible that the video driver may have a bug, but that is very
highly unlikely for this case based on the information provided.  If that
does however turn out to be the case, a bug report should be filed in XFree86
bugzilla at http://bugs.xfree86.org so that the "nv" driver maintainer (an
Nvidia employee) is aware of the issue and can investigate it.  Only someone
with in depth knowledge of the Nvidia hardware, and access to the
specifications would be able to investigate such an issue, which pretty much
means Mark Vojkovich from Nvidia as their specifications are not made available
to the public or open source developers, not even under NDA.

Hope this helps.
Comment 4 Mike A. Harris 2003-09-24 01:47:54 EDT
Closing as NOTABUG.
Comment 5 Giorel 2003-09-24 22:03:33 EDT
Thanks.

Note You need to log in before you can comment on or make changes to this bug.