Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1049785 - A redundant image copy is created when creating a volume from a glance image. (All-in-One)
Summary: A redundant image copy is created when creating a volume from a glance image....
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: RDO
Classification: Community
Component: openstack-cinder
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Eric Harney
QA Contact: Dafna Ron
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-08 08:37 UTC by Eduardo Warszawski
Modified: 2016-04-26 21:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-25 18:51:11 UTC


Attachments (Terms of Use)

Description Eduardo Warszawski 2014-01-08 08:37:02 UTC
Description of problem:
A redundant image copy is created when creating a volume from a glance image.
Since it is a all in one setup there is no need for craeate an intermediate copy.

Version-Release number of selected component (if applicable):


How reproducible:
cinder create --image-id 3d597ebb-ce76-4323-a71d-f45a3b08ca22 7


Actual results:
The image is copied to a temporal one.
2228508 -rw-------. 1 cinder cinder 294M Jan  7 16:33 /var/lib/cinder/conversion/tmp5wf91A                                                                                                                                                   
2228506 -rw-r-----. 1 glance glance 294M Jan  7 16:17 /var/lib/glance/images/3d597ebb-ce76-4323-a71d-f45a3b08ca22                                                                                                                            

# diff -s /var/lib/cinder/conversion/tmp5wf91A /var/lib/glance/images/3d597ebb-ce76-4323-a71d-f45a3b08ca22
Files /var/lib/cinder/conversion/tmp5wf91A and /var/lib/glance/images/3d597ebb-ce76-4323-a71d-f45a3b08ca22 are identical


Expected results:
Since is the same node there is no need for the copy.

Additional info:

Comment 1 Eric Harney 2014-01-13 21:48:31 UTC
It looks like setting allowed_url_schemes=file in cinder.conf may allow this today.

Comment 3 Lars Kellogg-Stedman 2015-03-25 18:51:11 UTC
As Eric says in #1, this feature is already available.  You would need to set DEFAULT/show_image_direct_url=True in glance-api.conf and set allowed_direct_url_schemes=file in cinder.conf.


Note You need to log in before you can comment on or make changes to this bug.