Bug 1049801 - Running cuda on optimus laptops triggers selinux warnings
Summary: Running cuda on optimus laptops triggers selinux warnings
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy   
(Show other bugs)
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-08 09:12 UTC by Arno Mayrhofer
Modified: 2014-01-16 07:13 UTC (History)
4 users (show)

Fixed In Version: selinux-policy-3.12.1-116.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-16 07:13:14 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of all SELinux allerts (51.40 KB, text/plain)
2014-01-08 09:12 UTC, Arno Mayrhofer
no flags Details
Output in /var/log/messages (13.54 KB, text/plain)
2014-01-08 09:13 UTC, Arno Mayrhofer
no flags Details
List of all SELinux allerts (with policy 116) (9.09 KB, text/plain)
2014-01-14 08:53 UTC, Arno Mayrhofer
no flags Details

Description Arno Mayrhofer 2014-01-08 09:12:16 UTC
Created attachment 847030 [details]
List of all SELinux allerts

Description of problem:
When running a cuda program using optirun about 21 SELinux alerts are triggered in the progress.


Version-Release number of selected component (if applicable):
bumblebee.x86_64 3.2.1-4.fc20 @bumblebee                              
bumblebee-nonfree-release.noarch 1.1-1 @/bumblebee-nonfree-release-1.1-1.noarch
bumblebee-nvidia.x86_64 331.20-1.fc20 @bumblebee-nonfree                      
bumblebee-release.noarch 1.1-1 @/bumblebee-release-1.1-1.noarch
bbswitch.x86_64 0.7.0-1.fc20 @bumblebee
kernel.x86_64 3.12.6-300.fc20

Actual results: The program actually runs but seems to crash at the very end. The first 19 alerts are triggered when the program is launched. The last 2 when the program exits.

dmesg output while program runs:
[ 5531.540331] bbswitch: enabling discrete graphics
[ 5532.066102] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns=none
[ 5532.067734] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 1
[ 5532.067743] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  331.20  Wed Oct 30 17:43:35 PDT 2013
[ 5532.086642] nvidia 0000:01:00.0: irq 49 for MSI/MSI-X
[ 5532.093042] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 5532.093083] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 5532.093099] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 5532.093115] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 5532.093130] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 5532.093144] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 5532.093262] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 5532.093279] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 5532.982725] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 5649.233255] GPUSPH[8565]: segfault at 7fd4d6ce1316 ip 0000003701438b6d sp 00007fff6eb2fc40 error 4 in libc-2.18.so[3701400000+1b4000]
[ 5651.342691] [drm] Module unloaded
[ 5651.346500] bbswitch: disabling discrete graphics
[ 5651.346512] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 5651.357564] pci 0000:01:00.0: Refused to change power state, currently in D0

Note: GPUSPH is the name of the program. Output of /var/log/messages in next post.

I'm not sure if this is the right component, if not please change accordingly. If any further information is required let me know and I'll happily provide it.

Comment 1 Arno Mayrhofer 2014-01-08 09:13:19 UTC
Created attachment 847031 [details]
Output in /var/log/messages

Comment 2 Miroslav Grepl 2014-01-08 17:19:07 UTC
Has been fixed.

Comment 3 Arno Mayrhofer 2014-01-09 08:04:36 UTC
Can you be a bit more verbose? What did you alter and is it already available in testing?

Comment 4 Arno Mayrhofer 2014-01-09 09:52:56 UTC
Ah I updated just before and saw that there was one se update. Indeed the warnings are gone now when the program is started. However, when the program ends the last two warnings (20 and 21 in https://bugzilla.redhat.com/attachment.cgi?id=847030) still appear and the program crashes with a segfault (as seen in dmesg)

Comment 5 Miroslav Grepl 2014-01-10 09:44:54 UTC
A new update is coming today.

Comment 6 Fedora Update System 2014-01-13 22:58:27 UTC
selinux-policy-3.12.1-116.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-116.fc20

Comment 7 Arno Mayrhofer 2014-01-14 08:52:45 UTC
I updated to 116.fc20 and it seems to be better. There are still 4 remaining. Two of them when the cuda program starts, two of them when it ends. I will add an attachment in a second with the details from the alert browser.
Thanks already for the first round of patches.

Comment 8 Arno Mayrhofer 2014-01-14 08:53:31 UTC
Created attachment 849810 [details]
List of all SELinux allerts (with policy 116)

Comment 9 Fedora Update System 2014-01-15 06:00:00 UTC
Package selinux-policy-3.12.1-116.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-116.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0806/selinux-policy-3.12.1-116.fc20
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2014-01-16 07:13:14 UTC
selinux-policy-3.12.1-116.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.