Bug 104981 - RHN and up2date use inconsistent package version comparison algorithms
RHN and up2date use inconsistent package version comparison algorithms
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
All Linux
medium Severity high
: ---
: ---
Assigned To: Chip Turner
Fanny Augustin
:
Depends On:
Blocks: 101259
  Show dependency treegraph
 
Reported: 2003-09-24 07:04 EDT by Chris Ricker
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-02 10:58:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-09-24 07:04:09 EDT
I have systems subscribed to

* Red Hat Linux (Severn) 9.0.93 - Beta
* Red Hat Linux (Severn) 9.0.93 - Beta Updates

On these systems, up2date shows them as being fully updated. The RHN web
interface, however, consistently lists the following as being available for all
of these systems:

  	 gdb-5.3post-1.20021129.37 as an upgrade for gdb-5.3.90-0.20030710.21

The problem, I guess, is that RHN is comparing 5.3post as > 5.3.90, while
up2date is making the same comparison and finding 5.3post < 5.3.90 (neither
package has an epoch).

To avoid sanity issues for end users, the web front-end and the up2date
front-end really should use the same comparison algorithm, and both should be
consistent with rpm.

FWIW, when rpm makes the same comparison, it finds 5.3post < 5.3.90, so that's
what both up2date and RHN should do....

[kaboom@skuld kaboom]$ rpm -q gdb
gdb-5.3.90-0.20030710.29
[kaboom@skuld kaboom]$ sudo rpm -Fvh gdb-5.3post-1.20021129.37.i386.rpm 
[kaboom@skuld kaboom]$ rpm -q gdb
gdb-5.3.90-0.20030710.29
[kaboom@skuld kaboom]$
Comment 1 Chris Ricker 2003-09-24 07:06:36 EDT
BTW, I think it was a fairly recent change in rpm that in version comparison,
numbers are always greater than letters (so 90 > post). Presumably the RHN web
side just wasn't updated when that was changed....
Comment 2 Bret McMillan 2003-09-24 10:37:06 EDT
Reassigning to appropriate component...
Comment 3 Mihai Ibanescu 2003-09-24 11:12:20 EDT
This has been fixed, but not deployed to production yet.
Comment 4 Josef Komenda 2003-10-02 10:49:19 EDT
Chris,

This went live 09/30 - can you confirm? 
Comment 5 Chris Ricker 2003-10-02 10:58:37 EDT
Hmm, guess me closing this was lost in the Great Bugzilla Crash of '03 ;-)

It works for me now, thanks!

Note You need to log in before you can comment on or make changes to this bug.