Bug 104983 - xmltex fails to correctly render docbook ulink when url contains &
xmltex fails to correctly render docbook ulink when url contains &
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xmltex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-24 07:18 EDT by Paul Nasrat
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 10:26:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Nasrat 2003-09-24 07:18:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
In trying to build the develoment guide from fedora-docs project into a pdf it
fails with error.

A simple example xml:

<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook V4.1//EN"
 "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" >
 
<book>
 
<chapter><title>First chapter</title>
 
<para>
<ulink url="http://www.google.com/search?hl=en&amp;q=passivetex">
Google</ulink> for passivetex.
</para>
 
</chapter>
</book>


Version-Release number of selected component (if applicable):
xmltex-20000118-14.1

How reproducible:
Always

Steps to Reproduce:
1.  save xml bug.xml
2.  xmlto fo bug.xml
3.  xmltex bug.fo
    

Actual Results:  Errors with:

         0:external-destination = "url(http://www.google.com/search?hl=en&amp;q
=passivetex)"  >
! Missing \endcsname inserted.
<to be read again>
                   &
l.3 ...google.com/search?hl=en&amp;q=passivetex)">
                                                                                
?
! Emergency stop.
<to be read again>
                   &
l.3 ...google.com/search?hl=en&amp;q=passivetex)">
                                                                                
End of file on the terminal!


Expected Results:  Should cope with valid docbook xml &amp; in ulink url and get
a nice shiny pdf out

Additional info:

This is stopping the development guide being available as a pdf
Comment 1 Tim Waugh 2003-09-29 11:00:32 EDT
Hmm, this seems to be caused by the \xmlgrab in fotex.xmt's implementation of
basic-link.
Comment 2 Tim Waugh 2003-10-27 04:49:43 EST
I have reported this upstream, but not heard anything back yet.
Comment 3 Paul Nasrat 2003-10-27 05:28:22 EST
Cheers - do you have an upstream bugzilla no or a pointer to the appropriate
list archive.

Comment 4 Tim Waugh 2003-11-12 16:52:47 EST
No, I reported it in private mail.
Comment 5 Raphael Jacquot 2003-11-17 10:28:34 EST
easy, make &amp; be outputted as {\&} , as explained in
http://www.rpi.edu/~chos/latex.html
Comment 6 Tim Waugh 2003-11-17 11:21:15 EST
PassiveTeX/xmltex is quite twisty, and it's hard to see where/how to
do this.. :-(
Comment 7 Bill Nottingham 2006-08-07 21:41:38 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 8 John Thacker 2006-10-29 10:26:18 EST
Closing as CANTFIX per previous comment and lack of response.

Note You need to log in before you can comment on or make changes to this bug.