Bug 10499 - Bug with xdm and pam_env
Bug with xdm and pam_env
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-31 18:43 EST by jfalk
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 12:42:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jfalk 2000-03-31 18:43:17 EST
Garbled DISPLAY variable set from within xdm for the
Xsession script.
This happens if pam_env.conf has
defined REMOTEHOST and DISPLAY.

XFree86-devel-3.3.6-11
pam-0.68-7

Running modified Redhat 6.1 System

#
# First, some special variables
#
# Set the REMOTEHOST variable for any hosts that are remote, default
# to "localhost" rather than not being set at all
REMOTEHOST      DEFAULT=localhost OVERRIDE=@{PAM_RHOST}
#
# Set the DISPLAY variable if it seems reasonable
DISPLAY         DEFAULT=${REMOTEHOST}:0.0 OVERRIDE=${DISPLAY}
#
#
Comment 1 Mike A. Harris 2001-02-27 16:54:03 EST
I can't reproduce this in our latest release, please upgrade.

Note You need to log in before you can comment on or make changes to this bug.