Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1049911 - "Approve All Connections" is ambiguous
Summary: "Approve All Connections" is ambiguous
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: control-center
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Bastien Nocera
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-08 13:14 UTC by Radek Bíba
Modified: 2015-11-19 08:24 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 08:24:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
mockup (45.25 KB, image/png)
2014-01-30 11:38 UTC, Allan Day
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2157 0 normal SHIPPED_LIVE control-center bug fix and enhancement update 2015-11-19 08:48:59 UTC

Description Radek Bíba 2014-01-08 13:14:07 UTC
Description of problem:
I set "Approve All Connections" to "ON" in Screen Sharing because I thought it meant that all connections would be allowed automatically. I also set up password protection so only I could connect remotely. However, when I tried to get back to my screen, I couldn't; I was locked out. The thing is, it's the other way around: "ON" means that all connection attempts must be manually approved by the local user. Go figure.

Would you please consider rewording the description of the switch?

Version-Release number of selected component (if applicable):
vino-3.8.1-7.el7

Comment 1 Radek Bíba 2014-01-08 13:20:15 UTC
FWIW, in vino-preferences, before it was deprecated, there was a nice checkbox:

"You must confirm each access to this machine"

Comment 3 Søren Sandmann Pedersen 2014-01-20 22:11:07 UTC
Unless I'm misunderstanding something, the UI would have to be changed in control-center.

Comment 4 Allan Day 2014-01-30 11:38:08 UTC
Created attachment 857428 [details]
mockup

I agree that the options need to be clearer here. Part of the issue is the wording of the label. The other part is that the two check boxes are ambiguous - it isn't spelled out what will happen when neither of them are checked.

I've developed the attached mockup in consultation with the vino and control center maintainers. It makes the different options clear, and also deliberately prevents people from leaving their systems open (this is still possible for those who have expertise; we just won't show it in the UI).

Note that a password will need to be generated when "require a password" is selected.

Comment 5 Radek Bíba 2014-01-30 12:16:06 UTC
Looks great!

Comment 7 Matthias Clasen 2014-02-18 02:46:55 UTC
too late for 7.0

Comment 15 errata-xmlrpc 2015-11-19 08:24:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2157.html


Note You need to log in before you can comment on or make changes to this bug.