Bug 1049936 - hibernate3: FTBFS in rawhide
Summary: hibernate3: FTBFS in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hibernate3
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: gil cattaneo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1068134
TreeView+ depends on / blocked
 
Reported: 2014-01-08 14:12 UTC by Mikolaj Izdebski
Modified: 2014-09-03 14:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-03 14:42:49 UTC
Type: ---


Attachments (Terms of Use)

Description Mikolaj Izdebski 2014-01-08 14:12:31 UTC
Description of problem:
Package hibernate3 fails to build from source in rawhide.

Koji scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=6373262

This is likely caused by CGlib update in rawhide:

[ERROR] /builddir/build/BUILD/hibernate-orm-3.6.10.Final/hibernate-core/src/main/java/org/hibernate/bytecode/cglib/CglibClassTransformer.java:[83,33] incompatible types
  required: org.objectweb.asm.ClassWriter
  found:    net.sf.cglib.core.DebuggingClassWriter

Version-Release number of selected component (if applicable):
3.6.10-12

Additional info:
[1] http://fedoraproject.org/wiki/Packaging:Java
[2] http://fedoraproject.org/wiki/Packaging:Guidelines


Note You need to log in before you can comment on or make changes to this bug.