Bug 1049994 - [RFE][HC] - Allow choosing network interface for gluster domain traffic
Summary: [RFE][HC] - Allow choosing network interface for gluster domain traffic
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
: 1177778 (view as bug list)
Depends On:
Blocks: 1057450 Generic_Hyper_Converged_Host rhsc_qe_tracker_everglades 1193999 1224281 Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2014-01-08 15:23 UTC by Juan Pablo Lorier
Modified: 2016-03-11 07:19 UTC (History)
14 users (show)

Fixed In Version: ovirt-engine-3.6.0-0.0.master.20150515172356.git426b5a1
Doc Type: Enhancement
Doc Text:
Feature: Add all interfaces of hosts in a glusterfs cluster for been able to choose which use for gluster traffic Reason: Not allowing to choose which interface of the bricks to use causes the bricks to use a no optimal interface for gluster traffic and causes errors in host monitoring by engine. Result (if any): Better utilization of network resources.
Clone Of:
: 1224281 (view as bug list)
Environment:
Last Closed: 2016-03-11 07:19:31 UTC
oVirt Team: Gluster
rule-engine: ovirt-3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 37471 master MERGED engine: Add gluster role to network cluster Never
oVirt gerrit 37476 master MERGED webadmin: Gluster network role in UI Never
oVirt gerrit 37558 master MERGED engine: Enhance brick to support storage network Never
oVirt gerrit 38148 master MERGED engine: Changes to brick sync for storage network Never
oVirt gerrit 38149 master MERGED engine: Peer probing with alternate addresses Never
oVirt gerrit 38177 master MERGED engine: Validate change to gluster network Never
oVirt gerrit 38708 master MERGED engine: Version check for gluster network role feature Never
oVirt gerrit 39085 master MERGED webadmin: Show networks tab in gluster only mode Never
oVirt gerrit 39234 master MERGED webadmin: Showing network sub-tabs in gluster only mode Never
oVirt gerrit 39709 ovirt-engine-3.5-gluster MERGED engine: Add gluster role to network cluster Never
oVirt gerrit 40045 ovirt-engine-3.5-gluster MERGED webadmin: Gluster network role in UI Never
oVirt gerrit 40046 ovirt-engine-3.5-gluster MERGED engine: Enhance brick to support storage network Never
oVirt gerrit 40047 ovirt-engine-3.5-gluster MERGED engine: Changes to brick sync for storage network Never
oVirt gerrit 40048 ovirt-engine-3.5-gluster MERGED engine: Peer probing with alternate addresses Never
oVirt gerrit 40137 ovirt-engine-3.5-gluster MERGED webadmin: Show networks tab in gluster only mode Never
oVirt gerrit 40146 ovirt-engine-3.5-gluster MERGED engine: Validate change to gluster network Never
oVirt gerrit 40148 ovirt-engine-3.5-gluster MERGED engine: Version check for gluster network role feature Never
oVirt gerrit 40224 ovirt-engine-3.5-gluster MERGED webadmin: Showing network sub-tabs in gluster only mode Never

Description Juan Pablo Lorier 2014-01-08 15:23:13 UTC
Description of problem:

When creating a new gluster volume the default interface used for gluster traffic is the ovirtmgmt though threre are other interfaces available. This causes network saturation.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Create a new gluster volume in a glusterfs domain
2.you can choose only the ovirtmgmt ip from the drop down menu when adding bricks
3.

Actual results:
Only ovirtmgmt interface is used for gluster traffic creating a bottleneck and render hosts unreachable during heavy disk workloads (like importing a vm)

Expected results:
Been able to choose among all interfaces of the hosts.

Additional info:

Comment 1 Juan Pablo Lorier 2014-01-08 15:42:29 UTC
One more thing is that this is causing the cluster to be unusable as it keeps bringing hosts down in engine when I try to import a vm (it uses a lot of bandwith). There's a way to change this after the volume is created by using gluster commands, but I think it should be done straight at creation time within webadmin and else, have the posibility of changing it after the volume is active (someone could get new interfaces after having the volume in production).

.

Comment 2 Yaniv Lavi 2014-12-30 12:02:40 UTC
*** Bug 1177778 has been marked as a duplicate of this bug. ***

Comment 3 Yaniv Lavi 2015-04-08 07:56:36 UTC
Should this be on MODIFIED?

Comment 4 SATHEESARAN 2016-03-08 08:49:56 UTC
Tested with  3.6.3.4-1.el7.centos + gluster 3.7.5

Following are the observations,
1. I could create a separate logical network for gluster
2. I could assign a role gluster for that network
3. Volume created use this network

Based on the above marking this bug as verified


Note You need to log in before you can comment on or make changes to this bug.