Bug 1050002 - Missing dependency on python-matplotlib-qt4
Summary: Missing dependency on python-matplotlib-qt4
Keywords:
Status: CLOSED DUPLICATE of bug 1049624
Alias: None
Product: Fedora
Classification: Fedora
Component: python-matplotlib
Version: 20
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-08 15:32 UTC by Giulio Giuseppe Giusteri
Modified: 2014-01-08 17:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-08 17:44:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Giulio Giuseppe Giusteri 2014-01-08 15:32:19 UTC
Description of problem:

After upgrade from Fedora19 to Fedora20 the package python-matplotlib-qt4 is not installed, though it seems to be required by the module pyplot present in python-matplotlib.

Version-Release number of selected component (if applicable): 1.3.0-1.fc20.i686

Actual results:

# python 
Python 2.7.5 (default, Nov 12 2013, 16:45:58) 
[GCC 4.8.2 20131017 (Red Hat 4.8.2-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import matplotlib.pyplot
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/matplotlib/pyplot.py", line 98, in <module>
    _backend_mod, new_figure_manager, draw_if_interactive, _show = pylab_setup()
  File "/usr/lib/python2.7/site-packages/matplotlib/backends/__init__.py", line 25, in pylab_setup
    globals(),locals(),[backend_name])
ImportError: No module named backend_qt4agg
>>> quit()

Expected results:
It should be possible to import matplotlib.pyplot without errors.

Additional info:

The command
rpm -q --requires python-matplotlib
does not list python-matplotlib-qt4

Comment 1 Paulo Andrade 2014-01-08 17:44:37 UTC

*** This bug has been marked as a duplicate of bug 1049624 ***


Note You need to log in before you can comment on or make changes to this bug.