Bug 1050006 - PermGen leak caused by MVEL dynamic optimizer
Summary: PermGen leak caused by MVEL dynamic optimizer
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: BRE
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: CR1
: 6.0.0
Assignee: Mario Fusco
QA Contact: Tomas Schlosser
URL:
Whiteboard:
Depends On:
Blocks: 1050308
TreeView+ depends on / blocked
 
Reported: 2014-01-08 15:37 UTC by Mario Fusco
Modified: 2014-08-06 20:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1050308 (view as bug list)
Environment:
Last Closed: 2014-08-06 20:17:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Mario Fusco 2014-01-08 15:37:10 UTC
When using the dynamic optimization, mvel holds a reference to the current ClassLoader causing a potential PermGen leak that is evident especially when multiple KieBases are created.

Switching to the reflective optimizer fixes this problem.

Comment 2 Mario Fusco 2014-01-08 17:41:03 UTC
Fixed by https://github.com/droolsjbpm/drools/commit/ca2611be9

Comment 3 Edson Tirelli 2014-01-08 20:04:55 UTC
This is a memory (permgen) leak. The fix is critical for 6.0.0.GA. Rajesh, QA, can you please review and set the flags. We have the fix, just waiting to cherry-pick into 6.0.0. Thank you.

Comment 4 Tomas Schlosser 2014-01-23 08:44:32 UTC
I was unable to reproduce this issue with BRMS CR1. I have reviewed the code change that was done and it seems to fix the original issue.


Note You need to log in before you can comment on or make changes to this bug.