Bug 105028 - Evo sends invalid EHLO
Summary: Evo sends invalid EHLO
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: evolution   
(Show other bugs)
Version: beta1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-24 19:49 UTC by David Woodhouse
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-11 08:31:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Woodhouse 2003-09-24 19:49:42 UTC
When connecting with IPv6 from a host with no reverse DNS, evo will send the
IPv6 literal in the EHLO without properly surrounding it in [].

It looks like camel_gethostbyaddr() is actually returning "2002:c1ed:....:a42a"
as if it were the host name, and Evo then just says "EHLO 2002:....:a42a". And
gets told to sod off by the mail server, because that violates RFC2822.

Comment 1 Jeremy Katz 2003-10-15 00:06:05 UTC
Will be fixed in next build.


Note You need to log in before you can comment on or make changes to this bug.