Bug 105034 - Bison 1.875 and gcc 3.3.1 incompatibility
Bison 1.875 and gcc 3.3.1 incompatibility
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: bison (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-24 16:13 EDT by Dan Williams
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 17:58:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2003-09-24 16:13:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Bison 1.875 (upstream) has an incompatibility with gcc 3.3.1 (using
Cambridge/Fedora Core).

http://mail.gnu.org/archive/html/bison-patches/2003-01/msg00047.html
http://mail.gnu.org/archive/html/bug-bison/2003-01/msg00083.html

The fix is supposed to be in the next version of Bison, but no greater than
1.875 has been released yet.  The problem is the __attribute__ (__unusued__)
right before the goto yerrlab2 statement.

Mandrake also supplies a patch which applies cleanly and works just fine against
Red Hat bison-1.875-3:
http://cvs.mandrakesoft.com/cgi-bin/cvsweb.cgi/SPECS/bison/


Version-Release number of selected component (if applicable):
bison-1.875-3

How reproducible:
Always

Steps to Reproduce:
1.  Get Fedora with Bison 1.875-3 and gcc 3.3.1
2.  Try to compile something that uses yacc
3.  For example, try to build OpenOffice.org 1.1, and build dies in idlc,
compiling parser.cxx
    

Additional info:
Comment 1 Roland McGrath 2003-09-24 17:58:53 EDT
bison-1.875-5 includes that upstream patch
Comment 2 Han-Wen Nienhuys 2003-09-27 05:05:13 EDT
where are we supposed to get bison-1.875-5? It's not on Rawhide (sep 27,
11:04:32 CEST)

Note You need to log in before you can comment on or make changes to this bug.