Bug 105044 - NFS Client Cache not refreshing
NFS Client Cache not refreshing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
8.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-24 17:22 EDT by Travis Waldher
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 17:25:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Travis Waldher 2003-09-24 17:22:43 EDT
Description of problem:
I'm not sure how to reply to that bug.

I am experiencing a similar problem.

I have an NFS server and a client.  I use a backup program to restore some 
files to a NFS export called server:/test.

The clients sees all the files just fine.

I then run a second restore to fill in the incremental data.

The client does NOT see the files.

I've tried the noac options, plus the actimeo=10 option with no difference in 
response.  I have tried NFS v2, and NFS v3.  Interestingly enough NFS v2 is a 
little more resiliant than NFS v3.  As I can sometimes cd in and out of that 
directory to get the files to show up on a ls.  Or just run a touch command 
and create a new file.  The worst case required me to unmount and remount the 
NFS connection, up until then, 80 hours later, NFS Client still hadn't figured 
out new files were on the server.

[root@cfs3 k12]# rpm -qa |grep nfs
redhat-config-nfs-1.0.1-3
nfs-utils-1.0.1-2

I understand there is a patched version of nfs-utils-1.0.1-2.8(?) but that was 
to deal with a vulnerability.  I would like to know if that patch would 
definitely resolve this problem, or if we have a new problem that needs to be 
fixed. 

Thanks,
Travis


Version-Release number of selected component (if applicable):


How reproducible:
EVerytime

Steps to Reproduce:
(This problem has existed before, but this is the only way I can make it 
repropduce-able.  Otherwise this problem is more random)

1. restore data from HP Omnibak
2. go to directory where I restored do an ls
3. do another restore in to the same directory to complete the restoration 
job.  (This restore fills gaps in what files should have been restored in the 
first place.)
4. while still in that same directory, do an ls.  (instead of seeing the 10-20 
new files that should be there, I see the same response as I got on step 2.  
From the NFS client.   If I do this on the NFS server, thigns operate normally.
    
    
Actual results:
(included in the steps for clarity)

Expected results:
NFS client should see changes made to filesystems as they happen.



Additional info:
noac and actimeo settings seem to have no effect.

sync is set on the server.
Comment 1 Steve Dickson 2004-06-15 17:25:49 EDT
This should be fixed in later kernels.... If not please reopen
Comment 2 david 2005-10-11 10:39:03 EDT
I have the same issue on AS3.0 (2.4.21-9.0.1.ELsmp) using nfs-utils-1.0.6-7.EL.

An nfs server shares out a directory to 4 clients as rw. Ocassionally when one 
of the clients updates a fine mounted by them, the changes do not appear on the 
other clients, or the server.

Again, the worst case required the nfs directory to be unmount and remount 
before the changes were picked up by the other clients, and the server.

Note You need to log in before you can comment on or make changes to this bug.