This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 10506 - tcpdump does not work correctly
tcpdump does not work correctly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tcpdump (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On: 10739
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-01 08:05 EST by persteinar.iversen
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-11 14:37:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description persteinar.iversen 2000-04-01 08:05:39 EST
The platform is a Dell PowerEdge 2400 running RedHat 6.2
The NIC seems to be Intel 82557-based.

The tcpdump that comes with RedHat 6.2 is not able to catch
packets other than broadcasts and packets directed at this server,
sniffing packets directed at another machine on the same 100Mb hub
does not work.

This must be a bug, as tcpdump 3.4 from ftp.ee.lbl.gov
works nicely when compiled on this machine.

-psi
Comment 1 Jeff Johnson 2000-05-14 14:36:59 EDT
What happens if you add -p? The man page is incorrect wrto the behavior
of ANK tcpdump, and needs fixing IIRC.
Comment 2 Jeff Johnson 2000-07-11 14:41:36 EDT
Fixed (by updating man page) in tcpdump-3.4-22.

Note You need to log in before you can comment on or make changes to this bug.