Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1050923 - Font warning when using matplotlib after upgrade from F19 to F20
Summary: Font warning when using matplotlib after upgrade from F19 to F20
Keywords:
Status: CLOSED DUPLICATE of bug 1047559
Alias: None
Product: Fedora
Classification: Fedora
Component: python-matplotlib
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-09 10:58 UTC by Marco Driusso
Modified: 2014-01-11 15:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-11 15:49:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Marco Driusso 2014-01-09 10:58:01 UTC
Description of problem:
When using some plot functions of the matplotlib.pyplot module (e.g. semilogy), the interpreter complains about some missing fonts. This happened only after the update from F19 to F20, which I did using fedup, without having any issue.
In F19 everything was working fine. The fonts which the interpreter complains about are all installed.


Version-Release number of selected component (if applicable):
python-matplotlib.x86_64 version 1.3.0-1.fc20


How reproducible:
Always reproducible when running the matplotlib.pyplot semilogy command.


Steps to Reproduce:
Run in the python interpreter
  
>>> import numpy as np
>>> import matplotlib.pyplot as plt
>>> x = np.abs(np.sinc(np.linspace(0, 2, 1000)))
>>> plt.semilogy(x)
>>> plt.show()


Actual results:
Obtain the plot, but also the following warnings:

>>> plt.show()
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['STIXGeneral'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1246: UserWarning: findfont: Could not match :family=Bitstream Vera Sans:style=normal:variant=normal:weight=normal:stretch=normal:size=12. Returning /usr/share/fonts/gnu-free/FreeSansOblique.ttf
  UserWarning)
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['STIXSizeOneSym'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1246: UserWarning: findfont: Could not match :family=Bitstream Vera Sans:style=normal:variant=normal:weight=bold:stretch=normal:size=12. Returning /usr/share/fonts/gnu-free/FreeSansOblique.ttf
  UserWarning)
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['STIXSizeThreeSym'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['STIXSizeFourSym'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['STIXSizeFiveSym'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['STIXSizeTwoSym'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1246: UserWarning: findfont: Could not match :family=Bitstream Vera Sans:style=italic:variant=normal:weight=normal:stretch=normal:size=12. Returning /usr/share/fonts/gnu-free/FreeSansOblique.ttf
  UserWarning)
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['STIXNonUnicode'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['cmb10'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['cmtt10'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['cmmi10'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['cmex10'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['cmsy10'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['cmr10'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))
/usr/lib64/python2.7/site-packages/matplotlib/font_manager.py:1236: UserWarning: findfont: Font family ['cmss10'] not found. Falling back to Bitstream Vera Sans
  (prop.get_family(), self.defaultFamily[fontext]))


Expected results:
Plot with no warnings.


Additional info:
$ python --version
Python 2.7.5

$ yum info python-matplotlib
Installed Packages
Name        : python-matplotlib
Arch        : x86_64
Version     : 1.3.0
Release     : 1.fc20

$fc-match STIXGeneral
STIX-Regular.otf: "STIX" "Regular"
$fc-match STIXSizeOneSym
STIX-Regular.otf: "STIX" "Regular"
$fc-match STIXSizeThreeSym
STIX-Regular.otf: "STIX" "Regular"
$fc-match STIXSizeFourSym
STIX-Regular.otf: "STIX" "Regular"
$fc-match STIXSizeFiveSym
STIX-Regular.otf: "STIX" "Regular"
$fc-match STIXSizeTwoSym
STIX-Regular.otf: "STIX" "Regular"
$fc-match STIXNonUnicode
STIX-Regular.otf: "STIX" "Regular"
$fc-match cmb10
LiberationSans-Regular.ttf: "Liberation Sans" "Regular"
$fc-match cmtt10
LiberationSans-Regular.ttf: "Liberation Sans" "Regular"
$fc-match cmmi10
LiberationSans-Regular.ttf: "Liberation Sans" "Regular"
$fc-match cmex10
LiberationSans-Regular.ttf: "Liberation Sans" "Regular"
$fc-match cmsy10
LiberationSans-Regular.ttf: "Liberation Sans" "Regular"
$fc-match cmr10
LiberationSans-Regular.ttf: "Liberation Sans" "Regular"
$fc-match cmss10
LiberationSans-Regular.ttf: "Liberation Sans" "Regular"

Comment 1 Paulo Andrade 2014-01-11 15:49:58 UTC

*** This bug has been marked as a duplicate of bug 1047559 ***


Note You need to log in before you can comment on or make changes to this bug.