Bug 1050945 - s-ramp-demos-shell-command quickstart not extending s-ramp shell
Summary: s-ramp-demos-shell-command quickstart not extending s-ramp shell
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance, Examples
Version: 6.0.0 GA
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: CR1
: ---
Assignee: Eric Wittmann
QA Contact: Stefan Bunciak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-09 11:58 UTC by Stefan Bunciak
Modified: 2014-02-06 15:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1041334 0 unspecified CLOSED Maven repo - Cannot build s-ramp-demos-switchyard quickstart 2021-02-22 00:41:40 UTC

Description Stefan Bunciak 2014-01-09 11:58:32 UTC
Description of problem:

META-INF/services/org.overlord.sramp.shell.api.ShellCommandProvider is not packed with the quickstart which probably causes the new command not to work in the s-ramp shell. 

Version-Release number of selected component (if applicable):
* 6.0.0.ER8

How reproducible:


Steps to Reproduce:
1. Follow s-ramp-demos-shell-command quickstart instructions
2.
3.

Actual results:

* s-ramp shell is not extended with the jvm command.

Expected results:


Additional info:
I tried to use jar with the command extension from Beta and it worked with the ER8 shell. Beta quickstart contains META-INF/services directory.

Comment 1 Eric Wittmann 2014-01-09 14:11:55 UTC
Thank you for not only finding this but also figuring out WHY it's not working!  :)

The build was excluding META-INF accidentally.  Kurt has fixed that problem and everything should be working in CR1.

Comment 2 kconner 2014-01-09 16:30:51 UTC
There was a second fix required to include the META-INF, covered by BZ 1041334

Comment 3 Stefan Bunciak 2014-01-16 13:22:00 UTC
Verified in FSW 6.0.0.CR1


Note You need to log in before you can comment on or make changes to this bug.