Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1051018 - satellite-sync should print names of files it was unable to download
Summary: satellite-sync should print names of files it was unable to download
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization
Version: 560
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gennadii Altukhov
QA Contact: Radovan Drazny
URL:
Whiteboard:
Depends On:
Blocks: sat570-triage
TreeView+ depends on / blocked
 
Reported: 2014-01-09 14:51 UTC by Jan Hutař
Modified: 2016-06-02 12:32 UTC (History)
6 users (show)

Fixed In Version: spacewalk-backend-2.3.3-40-sat
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-02 12:32:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1200 0 normal SHIPPED_LIVE Satellite 5.7 bug fix update 2016-06-02 16:32:31 UTC

Description Jan Hutař 2014-01-09 14:51:30 UTC
Description of problem:
When there is some mismatch in sizes of files Hosted provides as part of KS tree, satellite-sync only complains about incorrect size, but do not show filenames.


Version-Release number of selected component (if applicable):
spacewalk-backend-tools-2.0.3-18.el6sat.noarch


How reproducible:
Yesterday it was, but might be fixed now.


Steps to Reproduce:
1. Yesterday you were able to reproduce by syncing RHEL7 HTB channel:
   # satellite-sync -c rhel-x86_64-server-7-htb -c rhn-tools-rhel-x86_64-server-7-htb --debug-level=5


Actual results:
[...]
07:16:27 Downloading kickstartable trees files
07:16:27    Retrieving / parsing kickstart tree files: rhel-x86_64-server-7-htb (7)
            ________________________________________
Downloading:07:17:55 Error: expected 247746560 bytes, got 247840768 bytes
#####07:18:12 Error: expected 31817984 bytes, got 31728424 bytes
######07:18:27 Error: expected 30014748 bytes, got 29929332 bytes
######07:18:34 Error: expected 4813616 bytes, got 4813520 bytes
#####07:18:49 Error: expected 31817984 bytes, got 31728424 bytes
######07:19:08 Error: expected 30014748 bytes, got 29929332 bytes
######07:19:15 Error: expected 4813616 bytes, got 4813520 bytes
###### - complete
07:19:15    Retrieving / parsing kickstart tree files: rhn-tools-rhel-x86_64-server-7-htb (NONE RELEVANT)
[...]


Expected results:
Error message should contain name of the problematic file.

Comment 4 Gennadii Altukhov 2016-01-19 13:32:21 UTC
taking...

Comment 5 Gennadii Altukhov 2016-01-21 13:40:22 UTC
spacewalk.git:
bc6f24f4d64129d84b9627a4d7a74ce22e6980c4

Changes to fix bug:

0) Added filename to error message. Now it looks like:

10:37:40 Error: file /var/satellite/redhat/NULL/1ba/libertas-sd8787-firmware/20140804-0.1.git6bce2b0.el7_0/noarch/1ba2145261afd78ad1843a0670fea71f64c92de2722210513fdd32b050c4f89a/libertas-sd8787-firmware-20140804-0.1.git6bce2b0.el7_0.noarch.rpm has wrong size. Expected 318776 bytes, got 318775 bytes

Comment 7 Tomáš Kašpárek 2016-04-25 09:12:23 UTC
correct commit id in spacewalk.git(master): aeab534b35a6d7f6e33c1b22f96cf2719f9ff6f7

Comment 9 Radovan Drazny 2016-05-12 12:23:56 UTC
Verified on spacewalk-backend-tools-2.3.3-41.el6sat. In case of size mismatch there is an error message similar to the example in the comment #5, containing full path and name of the file with size mismatch.

VERIFIED

Comment 11 errata-xmlrpc 2016-06-02 12:32:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1200


Note You need to log in before you can comment on or make changes to this bug.