Bug 1051230 - drilling down int monitoring probes causes an internal server error
Summary: drilling down int monitoring probes causes an internal server error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 2.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space21
TreeView+ depends on / blocked
 
Reported: 2014-01-09 21:41 UTC by Paul Robert Marino
Modified: 2014-03-04 13:08 UTC (History)
1 user (show)

Fixed In Version: spacewalk-java-2.1.111-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-04 13:06:53 UTC


Attachments (Terms of Use)

Description Paul Robert Marino 2014-01-09 21:41:27 UTC
Description of problem:

when ever you try to drill down into the details of a monitoring probe the server throws off an internal server error and sends out a trace email.

Version-Release number of selected component (if applicable):


How reproducible:

every time

Steps to Reproduce:

go to Monitoring -> <server name> -> <Probe Description>
or go to  Systems -> Overview -> Health -> <Probe>
or via any of the many other ways to drill down into the probe details

Actual results:

Internal Server Error

Expected results:

I should get a screen where I can view and or edit details about the probe

Additional info:

traceback 
"
The following exception occurred while executing this request:
GET /rhn/systems/details/probes/ProbeDetails.do

Date:1/9/14 4:21:01 PM EST
Headers:
  host: <Spacewalk host name here>
  user-agent: Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20100101 Firefox/25.0
  accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  accept-language: en-US,en;q=0.5
  accept-encoding: gzip, deflate
  referer: https://<Spacwalk host name here>/rhn/systems/details/probes/ProbesList.do?sid=1000010058
  cookie: JSESSIONID=375EA8CEF4F4A2130D17115518F7132E; DWRSESSIONID=UMxasSs0HV2ExgCBAiyFLe4fBck; pxt-session-cookie=52985x8d958f631e130bf050d891fa1d9d9c51
  connection: keep-alive

Request:
Local Name = <Spacewalk host name here>
Server Name = <Spacewalk host name here>
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@68bdccb2[session=StandardSession[375EA8CEF4F4A2130D17115518F7132E]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, javax.servlet.jsp.jstl.fmt.timeZone.request, javax.servlet.error.servlet_name, javax.servlet.request.key_size, probe, javax.servlet.request.ssl_session, javax.servlet.error.message, innernavtitle, org.apache.struts.action.MESSAGE, metrics, javax.servlet.request.cipher_suite, javax.servlet.error.request_uri, show_graph, is_suite_probe, end, org.apache.struts.action.MODULE, probeDetailsForm, status, javax.servlet.error.status_code, requestedUri, show_log, system, start, session, selected_metrics, javax.servlet.error.exception, org.apache.struts.action.mapping.instance, 


User Information:
User pmarino (id 1, org_id 1)

Exception:
javax.servlet.ServletException: javax.servlet.jsp.JspException: Error writing to JSP file:
	at org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:858)
	at org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:791)
	at org.apache.jsp.WEB_002dINF.pages.systems.probes.details_jsp._jspService(Unknown Source)
	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:646)
	at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:436)
	at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:374)
	at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:302)
	at org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1078)
	at org.apache.struts.action.RequestProcessor.processForwardConfig(RequestProcessor.java:396)
	at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:232)
	at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:102)
	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1913)
	at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:449)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:127)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.opensymphony.sitemesh.webapp.SiteMeshFilter.obtainContent(SiteMeshFilter.java:129)
	at com.opensymphony.sitemesh.webapp.SiteMeshFilter.doFilter(SiteMeshFilter.java:77)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:100)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:57)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:769)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:698)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:891)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
	at java.lang.Thread.run(Thread.java:701)
Caused by: java.lang.IllegalArgumentException: Unknown icon type: "fa-copy".
	at com.redhat.rhn.frontend.taglibs.IconTag.renderStartTag(IconTag.java:195)
	at com.redhat.rhn.frontend.taglibs.ToolbarTag.renderActionLink(ToolbarTag.java:674)
	at com.redhat.rhn.frontend.taglibs.ToolbarTag.renderMiscLink(ToolbarTag.java:644)
	at com.redhat.rhn.frontend.taglibs.ToolbarTag.doStartTag(ToolbarTag.java:505)
	at org.apache.jsp.WEB_002dINF.pages.systems.probes.details_jsp._jspx_meth_rhn_005ftoolbar_005f2(Unknown Source)
	at org.apache.jsp.WEB_002dINF.pages.systems.probes.details_jsp._jspx_meth_c_005fif_005f3(Unknown Source)
	... 51 more

"

Comment 1 Michael Mráka 2014-01-10 08:13:46 UTC
Fixed in spacewalk master branch by
commit d6d0859b93fe6c65789f34ad6674fefd3c9ba212
    1051230 - fixed icon name
    Caused by: java.lang.IllegalArgumentException: Unknown icon type: "fa-copy".
            at com.redhat.rhn.frontend.taglibs.IconTag.renderStartTag

Comment 2 Paul Robert Marino 2014-01-12 15:48:28 UTC
fix confirmed
but it revealed an other bug in the edit page related to bug 1048981 which is a Firefox rendering issue.

Comment 3 Matej Kollar 2014-01-17 12:15:48 UTC
Switching MODIFIED Spacewalk bugs to ON_QA before 2.1 release.

Comment 4 Matej Kollar 2014-03-04 13:06:53 UTC
Spacewalk 2.1 has been released.
https://fedorahosted.org/spacewalk/wiki/ReleaseNotes21

Comment 5 Matej Kollar 2014-03-04 13:08:39 UTC
Spacewalk 2.1 has been released.
https://fedorahosted.org/spacewalk/wiki/ReleaseNotes21


Note You need to log in before you can comment on or make changes to this bug.