Bug 1051364 - libvirt monitor socket didn't show up sometimes
libvirt monitor socket didn't show up sometimes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Martin Kletzander
Virtualization Bugs
: Reopened, Upstream
Depends On: 892273 895901
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-10 01:49 EST by Martin Kletzander
Modified: 2016-04-26 09:38 EDT (History)
12 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-31.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 892273
Environment:
Last Closed: 2014-10-14 00:19:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Martin Kletzander 2014-01-17 02:48:24 EST
Hopefully fixed upstream by v1.2.1-11-gfe89b68:

commit fe89b687a02d1a8e1dce695a67b4f9d2c254d7b9
Author: Martin Kletzander <mkletzan@redhat.com>
Date:   Thu Jan 9 07:57:59 2014 +0100

    qemu: Change the default unix monitor timeout
Comment 6 yanbing du 2014-04-14 05:11:21 EDT
It's a tiny fix to update unix monitor timeout from 3 to 30(seconds). Update libvirt to libvirt-0.10.2-32.el6, and following the steps in https://bugzilla.redhat.com/show_bug.cgi?id=892273#c19, domain can start normally.
If change the TIMEOUT in the qemu wrapper to more than 30 seconds, it will fail as expected:
# virsh start rhel6
error: Failed to start domain rhel6
error: internal error Timed out while reading console log output: 

So move bug to VERIFIED.
Comment 8 errata-xmlrpc 2014-10-14 00:19:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1374.html

Note You need to log in before you can comment on or make changes to this bug.