Bug 10514 - multi volume dump does not work
multi volume dump does not work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dump (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-02 01:52 EST by dellis
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-27 12:10:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dellis 2000-04-02 01:52:35 EST
The dump that comes with RH6.2 (dump-0.4b15-1) barfs on multi volume sets.
Simple upgrade to dump-0.4b16-1 makes it work fine.
Comment 1 romain 2000-05-14 10:50:59 EDT
The problem is that dump-0.4b15-1 doesn't completely close the tape drive,
so it can't reopen the drive.  Where can one find dump-0.4b16-1?

+ /sbin/dump -b 32 -d 61000 -B 320 -f /dev/st0 /d5
  DUMP: Date of this level 0 dump: Sun May 14 07:32:55 2000
  DUMP: Date of last level 0 dump: the epoch
  DUMP: Dumping /dev/hdd5 (/d5) to /dev/st0
  DUMP: Label: none
  DUMP: mapping (Pass I) [regular files]
  DUMP: mapping (Pass II) [directories]
  DUMP: estimated 1978040 tape blocks on 5137.89 tape(s).
  DUMP: Volume 1 started at: Sun May 14 07:32:56 2000
  DUMP: dumping (Pass III) [directories]
  DUMP: Closing /dev/st0
  DUMP: Volume 1 completed at: Sun May 14 07:32:56 2000
  DUMP: Change Volumes: Mount volume #2
  DUMP: Is the new volume mounted and ready to go?: ("yes" or "no") yes
  DUMP: Cannot open output "/dev/st0".
  DUMP: Do you want to retry the open?: ("yes" or "no") no

fuser /dev/st0 shows that two instances of dump that didn't close the device.
Comment 2 Stelian Pop 2000-06-03 18:31:35 EDT
'man dump | grep http'

Stelian.

Note You need to log in before you can comment on or make changes to this bug.