Bug 1051462 - When message in Problems panel contains long word it is not displayed fully
Summary: When message in Problems panel contains long word it is not displayed fully
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ER1
: 6.0.1
Assignee: manstis
QA Contact: Jan Hrcek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-10 10:41 UTC by Jan Hrcek
Modified: 2014-08-06 19:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 19:58:08 UTC
Type: Bug


Attachments (Terms of Use)
Message not fully displayed (151.91 KB, image/png)
2014-01-10 10:41 UTC, Jan Hrcek
no flags Details

Description Jan Hrcek 2014-01-10 10:41:26 UTC
Created attachment 848130 [details]
Message not fully displayed

Description of problem:
When error message in problems panel contains long words (like fully qualified class name) the message is not displayed fully. See screenshot.

Version-Release number of selected component (if applicable):
BPMS 6.0.0 ER7 deployed on EAP 6.1 (in all browsers)

How reproducible:
Always

Steps to Reproduce:
1. Make something, that makes veeery long word be part of error message text in the Problems panel.

Actual results:
The long word is not wrapped around and cannot be read fully, because problem text field has fixed width.

Expected results:
If the Problems panel is to be useful as a debugging tool, it should display the message fully.

One simple solution that comes to my mind would be to use CSS property "word-wrap: break-word" which would force long words to wrap to the next line if they are too long for their container.

The other, more complicated but also more elegant solution would be to enable resizing of the problem panel's columns, so user can resize them according to his needs.

Comment 2 manstis 2014-01-20 17:38:14 UTC
Columns are now resizable.

Comment 5 Jan Hrcek 2014-02-19 13:54:38 UTC
Ok, verified with BPMS 6.0.1 ER1


Note You need to log in before you can comment on or make changes to this bug.