Bug 1051478 - XFS can't be used for / and /boot which needs to be there in documentation
Summary: XFS can't be used for / and /boot which needs to be there in documentation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Installation_Guide
Version: 6.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Petr Bokoc
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-10 11:43 UTC by Pushpendra Chavan
Modified: 2018-12-04 16:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-30 12:45:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 30949 0 None None None Never
Red Hat Knowledge Base (Solution) 31707 0 None None None Never
Red Hat Knowledge Base (Solution) 667273 0 None None None Never

Description Pushpendra Chavan 2014-01-10 11:43:18 UTC
Description of problem:

During installation of Red Hat Enterprise Linux 6, one can not format / and /boot with XFS filesystem, which is available in filesystem dropdown box. We need to add some more information into the documentation to make these points clear.

1. During installation, one can not format / and /boot with XFS, this is NOT supported.
2. But non-root partitions can be created and formatted because anaconda has its own userspace utilities to do so, post installation one has to register to RHN and install xfsprogs from RHEL Scalable File System channel and manage the xfs filesystem.


Version-Release number of selected component (if applicable):
RHEL6 Installation Guide

How reproducible:
Always

Steps to Reproduce:
1. See the documentation, its confusing when XFS comes in.

Actual results:
its not mentioned anywhere that root volume should not be formatted with XFS.

Expected results:
It should have been mentioned and clear.

Additional info:
I have created a Knowledgebase for this.

https://access.redhat.com/site/solutions/667273

Comment 2 Ruediger Landmann 2014-01-13 05:47:25 UTC
This is a bug in the document itself; changing components.

Comment 4 Eric Sandeen 2014-01-14 20:38:23 UTC
(In reply to Pushpendra Chavan from comment #0)
> Description of problem:
> 
> During installation of Red Hat Enterprise Linux 6, one can not format / and
> /boot with XFS filesystem, which is available in filesystem dropdown box. We
> need to add some more information into the documentation to make these
> points clear.
> 
> 1. During installation, one can not format / and /boot with XFS, this is NOT
> supported.
> 2. But non-root partitions can be created and formatted because anaconda has
> its own userspace utilities to do so

Oof, ok, mkfs.xfs _is_ in the installer image.  Well that's a surprise.

> Actual results:
> its not mentioned anywhere that root volume should not be formatted with XFS.

"should" not or "can" not?  I didn't think it was possible, but at least w/ my test on RHEL6.5, it is present and possible to mkfs.xfs .... hm.

-Eric

Comment 5 Pushpendra Chavan 2014-01-15 07:22:17 UTC
(In reply to Eric Sandeen from comment #4)

> 
> Oof, ok, mkfs.xfs _is_ in the installer image.  Well that's a surprise.

Yes, I was able to create an XFS non-root partition during installation. 

[root@localhost ~]# cat /proc/mounts  | grep " xfs "
/dev/vda5 /pc xfs rw,seclabel,relatime,attr2,delaylog,noquota 0 0


> 
> "should" not or "can" not?  

"can" not :D

> I didn't think it was possible, but at least w/
> my test on RHEL6.5, it is present and possible to mkfs.xfs .... hm.

For root volumes, we can not use the XFS filesystem but for non-root, also the binary you mentioned mkfs.xfs is not provided in normal rhel base channel, but through the Scalable File System Channel. See following.

[root@localhost ~]# rhn-channel -l
rhel-x86_64-server-6
[root@localhost ~]# yum whatprovides "*/mkfs.xfs"
Loaded plugins: product-id, rhnplugin, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
rhel-x86_64-server-6                                     | 1.5 kB     00:00     
rhel-x86_64-server-6/primary                             |  16 MB     00:00     
rhel-x86_64-server-6                                                12139/12139
rhel-x86_64-server-6/filelists                           |  29 MB     00:00     
No Matches found

[root@localhost ~]# rhn-channel -c  rhel-x86_64-server-sfs-6 --add
Username: admin
Password: 

[root@localhost ~]# rhn-channel -l
rhel-x86_64-server-6
rhel-x86_64-server-sfs-6
[root@localhost ~]# yum whatprovides "*/mkfs.xfs"
Loaded plugins: product-id, rhnplugin, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
rhel-x86_64-server-sfs-6                                 | 1.5 kB     00:00     
rhel-x86_64-server-sfs-6/primary                         | 6.7 kB     00:00     
rhel-x86_64-server-sfs-6                                                  38/38
rhel-x86_64-server-sfs-6/filelists                       | 3.8 kB     00:00     
xfsprogs-3.1.1-7.el6.x86_64 : Utilities for managing the XFS filesystem
Repo        : rhel-x86_64-server-sfs-6
Matched from:
Filename    : /sbin/mkfs.xfs



xfsprogs-3.1.1-10.el6_4.1.x86_64 : Utilities for managing the XFS filesystem
Repo        : rhel-x86_64-server-sfs-6
Matched from:
Filename    : /sbin/mkfs.xfs



xfsprogs-3.1.1-6.el6.x86_64 : Utilities for managing the XFS filesystem
Repo        : rhel-x86_64-server-sfs-6
Matched from:
Filename    : /sbin/mkfs.xfs



xfsprogs-3.1.1-4.el6.i686 : Utilities for managing the XFS filesystem
Repo        : rhel-x86_64-server-sfs-6
Matched from:
Filename    : /sbin/mkfs.xfs



xfsprogs-3.1.1-6.el6.i686 : Utilities for managing the XFS filesystem
Repo        : rhel-x86_64-server-sfs-6
Matched from:
Filename    : /sbin/mkfs.xfs



xfsprogs-3.1.1-4.el6.x86_64 : Utilities for managing the XFS filesystem
Repo        : rhel-x86_64-server-sfs-6
Matched from:
Filename    : /sbin/mkfs.xfs



xfsprogs-3.1.1-7.el6.i686 : Utilities for managing the XFS filesystem
Repo        : rhel-x86_64-server-sfs-6
Matched from:
Filename    : /sbin/mkfs.xfs



xfsprogs-3.1.1-14.el6.x86_64 : Utilities for managing the XFS filesystem
Repo        : rhel-x86_64-server-sfs-6
Matched from:
Filename    : /sbin/mkfs.xfs



xfsprogs-3.1.1-10.el6.x86_64 : Utilities for managing the XFS filesystem
Repo        : rhel-x86_64-server-sfs-6
Matched from:
Filename    : /sbin/mkfs.xfs



xfsprogs-3.1.1-10.el6.i686 : Utilities for managing the XFS filesystem
Repo        : rhel-x86_64-server-sfs-6
Matched from:
Filename    : /sbin/mkfs.xfs



xfsprogs-3.1.1-10.el6_4.1.i686 : Utilities for managing the XFS filesystem
Repo        : rhel-x86_64-server-sfs-6
Matched from:
Filename    : /sbin/mkfs.xfs



xfsprogs-3.1.1-14.el6.i686 : Utilities for managing the XFS filesystem
Repo        : rhel-x86_64-server-sfs-6
Matched from:
Filename    : /sbin/mkfs.xfs

This binary is required to get xfs filesystem created, but during installation, its able to create filesystem xfs on non-root partitions whereas post installation, one can not get this binary because its not in the rhel base channel but in child channel of rhel which is rhel-x86_64-server-sfs-6

So my primary understanding is that anaconda has its own user space utilities to get partitions formatted with xfs in rhel6 whereas post installation, one cannot do that until and unless mkfs.xfs from xfsprogs is installed from rhel-x86_64-server-sfs-6 channel.

- pushpendra

Comment 6 Terry Bowling 2014-01-15 15:17:26 UTC
I've attached a few KCS documents to this BZ for additional clarity.

I also made some revisions and a recommended change to clarify this for KCS:
Can XFS be used for /boot and / as a filesystem in Red Hat Enterprise Linux 6?
https://access.redhat.com/site/solutions/667273

Regarding CAN:

From the RHEL 6 Installation guide:
9.15.5. Recommended Partitioning Scheme
  9.15.5.1. x86, AMD64, and Intel 64 systems
    "The GRUB bootloader in Red Hat Enterprise Linux 6.5 supports only the 
     ext2, ext3, and ext4 (recommended) file systems. You cannot use any other 
     file system for /boot, such as Btrfs, XFS, or VFAT."
16.17.2.1. File System Types
    "Note that the maximum size of an XFS partition the anaconda installer can 
     create is 100 TB."

So it seems clear that:
  * RHEL 6 Anaconda supports/creates XFS for non-root/boot filesystems.
  * RHEL 5 Anaconda has NO support for XFS

Regarding SHOULD:
The important thing is that the customer SHOULD NOT IF they need support.  If they have not purchased the Scalable File System, it puts them in a very awkward situation with GSS support and Sales.

 * Which package provides XFS (Red Hat Scalable File System)?
   https://access.redhat.com/site/solutions/31707

 * How do I create an XFS Filesystem?
   https://access.redhat.com/site/solutions/30949

Therefore, I propose this BZ be closed as WONTFIX as this is clearly defined in the Installation Guide that / and /boot are NOT possible, nor supported.

Our existing KCS's clarify that SFS needs to be purchases.

MAYBE the documentation guide should be updated to state that XFS is partially available so that customers who have purchased SFS can apply it at install time.  And make the distinction that customers "should" NOT use if if they have not purchased support for SFS.

Comment 7 Eric Sandeen 2014-01-15 20:15:54 UTC
Just a note, Anaconda will also actively prevent you from creating an xfs filesystem on /boot or root.

To be honest, I'm not sure why mkfs.xfs is even available in the installer, I don't know if that was intentional or not.

Comment 8 Petr Bokoc 2014-07-03 14:15:30 UTC
(In reply to Terry Bowling from comment #6)
> Therefore, I propose this BZ be closed as WONTFIX as this is clearly defined
> in the Installation Guide that / and /boot are NOT possible, nor supported.
> 
> Our existing KCS's clarify that SFS needs to be purchases.
> 
> MAYBE the documentation guide should be updated to state that XFS is
> partially available so that customers who have purchased SFS can apply it at
> install time.  And make the distinction that customers "should" NOT use if
> if they have not purchased support for SFS.

Well, actually, the Installation Guide seems to mention XFS not being possible only on /boot, not on /, so I'll add that and explain in both spots that XFS is available otherwise.


Note You need to log in before you can comment on or make changes to this bug.