Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1051489 - SELinux is preventing /usr/bin/reporter-ureport from write access on the directory nssdb.
Summary: SELinux is preventing /usr/bin/reporter-ureport from write access on the dire...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1051482 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-10 12:24 UTC by Juan Orti
Modified: 2014-01-16 07:13 UTC (History)
4 users (show)

Fixed In Version: selinux-policy-3.12.1-116.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-16 07:13:40 UTC
Type: Bug


Attachments (Terms of Use)

Description Juan Orti 2014-01-10 12:24:33 UTC
Description of problem:
SELinux is preventing /usr/bin/reporter-ureport from write access on the directory nssdb.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that reporter-ureport should be allowed write access on the nssdb directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep reporter-urepor /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:cert_t:s0
Target Objects                nssdb [ dir ]
Source                        reporter-urepor
Source Path                   /usr/bin/reporter-ureport
Port                          <Unknown>
Host                          <removed>
Source RPM Packages           libreport-plugin-ureport-2.1.10-1.fc20.x86_64
Target RPM Packages
Policy RPM                    selinux-policy-3.12.1-106.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     <removed>
Platform                      Linux <removed> 3.12.6-300.fc20.x86_64 #1
                              SMP Mon Dec 23 16:44:31 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2014-01-10 12:30:32 CET
Last Seen                     2014-01-10 12:30:32 CET
Local ID                      123a54fa-f5a6-41f4-b9fe-e25515d3956a

Raw Audit Messages
type=AVC msg=audit(1389353432.100:5847): avc:  denied  { write } for  pid=2112 comm="reporter-urepor" name="nssdb" dev="dm-0" ino=2410 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cert_t:s0 tclass=dir


type=SYSCALL msg=audit(1389353432.100:5847): arch=x86_64 syscall=access success=no exit=EACCES a0=7f13b05fc660 a1=2 a2=7010 a3=7fffcb7dcdc0 items=0 ppid=2111 pid=2112 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=reporter-urepor exe=/usr/bin/reporter-ureport subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)

Hash: reporter-urepor,abrt_t,cert_t,dir,write

Comment 1 Juan Orti 2014-01-10 14:52:40 UTC
This happens after configuring a server to send abrt reports to a remote server using scp

Also see bug #1051482

Comment 2 Miroslav Grepl 2014-01-13 08:28:53 UTC
*** Bug 1051482 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2014-01-13 08:59:19 UTC
commit dbf110f0e84ff338b9c1af2856bc373dc131ff4b
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Mon Jan 13 09:59:05 2014 +0100

    Dontaudit access check for abrt on cert_t

Comment 4 Fedora Update System 2014-01-13 22:59:00 UTC
selinux-policy-3.12.1-116.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-116.fc20

Comment 5 Fedora Update System 2014-01-15 06:00:39 UTC
Package selinux-policy-3.12.1-116.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-116.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0806/selinux-policy-3.12.1-116.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-01-16 07:13:40 UTC
selinux-policy-3.12.1-116.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.