Bug 1051523 - Livecd-creator is disabling selinux
Summary: Livecd-creator is disabling selinux
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-10 14:08 UTC by Maros Zatko
Modified: 2014-02-26 14:01 UTC (History)
7 users (show)

Fixed In Version: livecd-tools-20.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-26 14:01:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Maros Zatko 2014-01-10 14:08:22 UTC
Description of problem:
Livecd-creator silently disables selinux, although it's subsequently re-enabled upon finish, the machine stays unprotected for a considerable amount of time

Version-Release number of selected component (if applicable):
19.6.1.fc19

How reproducible:
always

Steps to Reproduce:
1. vim $(which livecd-creator)
2. enter :151 (i.e. navigate to line 151)
3. observe selinux being disabled

Actual results:
The machine is exposed during ISO creation due to disabled selinux.

Expected results:
Protected machine while building ISO images.

Additional info:
There is a possibility that machine will stay exposed because of livecd-creator or python/library crash.

Comment 1 Brian Lane 2014-01-10 15:16:34 UTC
livecd-creator cannot run in enforcing mode.

Comment 2 Daniel Walsh 2014-01-10 16:32:33 UTC
Why not?

Comment 3 Brian Lane 2014-01-10 18:09:51 UTC
I don't remember exactly why, other than it not working.

Should it be able to? I've never had success with any of our image building tools and selinux. We also have other tools that don't work with enforcing turned on -- lorax, anconda image installs, and livemedia-creator when running anaconda on an image or directory install. IIRC the builders are running in permissive mode.

Comment 4 Daniel Walsh 2014-01-10 18:28:46 UTC
I know we have had livecd-tool working with SELinux in enforcing mode in the past.

/usr/bin/livecd-creator	--	system_u:object_r:livecd_exec_t:s0

I think the other tools if labeled livecd_exec_t should work also.

This is basically an unconfined domain that is allowed to put labels on disk that the kernel does not understand.

If you try the other tools with SELinux in enforcing mode, and labeled livecd_exec_t, it should work.  If you get AVC's I would like to look at them.

Comment 5 Brian Lane 2014-01-14 19:07:47 UTC
Looks like things have improved and the switch is no longer needed. I successfully built a couple test images with the host in enforcing for the whole build so I'll revert that patch.

Comment 6 Fedora Update System 2014-01-31 23:00:09 UTC
livecd-tools-20.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/livecd-tools-20.4-1.fc20

Comment 7 Fedora Update System 2014-02-01 00:52:41 UTC
livecd-tools-19.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/livecd-tools-19.9-1.fc19

Comment 8 Fedora Update System 2014-02-03 02:39:13 UTC
Package livecd-tools-20.4-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-20.4-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1911/livecd-tools-20.4-1.fc20
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-02-26 13:59:19 UTC
livecd-tools-19.9-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-02-26 14:01:42 UTC
livecd-tools-20.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.