Bug 1051591 - [GSS] (6.2.x) Clustered session memory leaking
Summary: [GSS] (6.2.x) Clustered session memory leaking
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: CR2
: EAP 6.2.2
Assignee: Brad Maxwell
QA Contact: Jitka Kozana
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On: 1039585
Blocks: eap62-cp02-blockers
TreeView+ depends on / blocked
 
Reported: 2014-01-10 16:29 UTC by Shay Matasaro
Modified: 2018-12-05 16:54 UTC (History)
11 users (show)

(edit)
A memory leak was found in earlier versions of JBoss EAP. Lock objects that were created to track session ownership per node were not removed from memory if the session timed out, resulting in the memory leak. This release of the product ensures the lock objects are removed when sessions time out, resolving the memory leak.
Clone Of:
(edit)
Last Closed: 2014-06-02 12:50:35 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1039585 None None None Never

Description Shay Matasaro 2014-01-10 16:29:53 UTC
portback of https://bugzilla.redhat.com/show_bug.cgi?id=1039585

Comment 1 Shay Matasaro 2014-01-10 17:47:36 UTC
https://github.com/jbossas/jboss-eap/pull/796

Comment 3 Scott Mumford 2014-01-17 05:01:01 UTC
Requesting information from bug assignee in order to complete release note text; specifically the Cause and Fix for this issue (see the 'Doc Text' field above).

Comment 6 Scott Mumford 2014-02-26 23:32:26 UTC
Redrafted Doc Text to prose format.


Note You need to log in before you can comment on or make changes to this bug.