Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1051615 - Race condition in neutron-l3-agent avoids SNAT to be translated properly in certain corner cases, traffic gets forwarded without NAT translation until connection is restarted.
Summary: Race condition in neutron-l3-agent avoids SNAT to be translated properly in c...
Keywords:
Status: CLOSED DUPLICATE of bug 1439847
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 6.0 (Juno)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 6.0 (Juno)
Assignee: Miguel Angel Ajo
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks: RHEL-OSP_Neutron_HA 1083887
TreeView+ depends on / blocked
 
Reported: 2014-01-10 17:01 UTC by Miguel Angel Ajo
Modified: 2021-03-11 14:12 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-17 18:12:10 UTC
Target Upstream Version:
majopela: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1267931 0 None None None Never

Description Miguel Angel Ajo 2014-01-10 17:01:50 UTC
Description of problem:
https://bugs.launchpad.net/neutron/+bug/1267931

It happens for traffic trying to traverse the router via NAT while the
router is started.

How reproducible:

40% of the time

Comment 5 Miguel Angel Ajo 2014-10-13 15:12:55 UTC
Closing as it works now in RHOS5/RHEL7.

Comment 9 Miguel Angel Ajo 2017-01-11 14:26:47 UTC
@pierre-andre Can you provide the kernel version where this was experienced?

Comment 10 Miguel Angel Ajo 2017-01-11 14:29:59 UTC
(In reply to Miguel Angel Ajo from comment #9)
> @pierre-andre Can you provide the kernel version where this was experienced?

I need that info to help me with reproducing the issue locally

Comment 20 Assaf Muller 2017-07-17 18:12:10 UTC

*** This bug has been marked as a duplicate of bug 1439847 ***


Note You need to log in before you can comment on or make changes to this bug.