Bug 1051689 - Regression in font rendering clarity
Summary: Regression in font rendering clarity
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: freetype
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-10 21:43 UTC by Michael Cronenworth
Modified: 2014-01-13 11:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-13 11:41:50 UTC


Attachments (Terms of Use)

Description Michael Cronenworth 2014-01-10 21:43:42 UTC
Description of problem: Font rendering changed in Fedora 20 (freetype 2.5.0) and is worse, IMHO, than previous Fedora releases.

freetype 2.4.11 (F19): http://i.imgur.com/TiAaFzX.png
freetype 2.5.0  (F20): http://i.imgur.com/vyCUUUX.png

Both images are from a F20 box. The problem is not isolated to LibreOffice and affects every application.


Version-Release number of selected component (if applicable):
freetype-2.5.0-4.fc20

Comment 1 Marek Kašík 2014-01-13 11:41:50 UTC
This was an intentional change. Freetype's upstream decided to disable the old CFF engine by default in 2.5.0. It was replaced by the new engine written by Google and Adobe.

See http://lists.nongnu.org/archive/html/freetype-devel/2013-05/msg00061.html, http://lists.nongnu.org/archive/html/freetype-devel/2013-06/msg00027.html and http://lists.nongnu.org/archive/html/freetype-devel/2013-05/msg00000.html.

Regards

Marek


Note You need to log in before you can comment on or make changes to this bug.