Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1051952 - RFE: Product Name for Content Specs List
Summary: RFE: Product Name for Content Specs List
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: PressGang CCMS
Classification: Community
Component: Web-UI
Version: 1.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.4
Assignee: Lee Newson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1037269
TreeView+ depends on / blocked
 
Reported: 2014-01-13 00:40 UTC by Misha H. Ali
Modified: 2014-02-23 23:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-23 23:43:57 UTC


Attachments (Terms of Use)

Description Misha H. Ali 2014-01-13 00:40:22 UTC
In the render view, the "Render fir Content Spec" drop down menu would be more useful if it contained a product name as well as the book name. I can't get a screenshot but for a topic I am currently looking at (ID 8849), the list contains six "Administration and Configuration Guide" items. This information would make more sense with a product name since information that is usually included in one type of guide (Admin Guide) would likely be in the same type of guide for other products.

For context, I use this drop down menu to see whether the topic is used in any other product's documentation before thinking about changes.

Comment 1 Lee Newson 2014-02-14 21:44:56 UTC
For your specific case you should probably be using the "Content Specs" tab, as that was what it was designed for.

As for the RFE, this is more than likely going to cause the dropdown to contain too much data to the point where you'd need a 1920x1080 displays to be able to read the additional information anyways. As such we possibly need a way to group the Content Specs in the list by product instead, or maybe have another dropdown where you select the product first. Anyways we'll need to look into this more closely when we take a look at implementing this RFE.

Comment 2 Lee Newson 2014-02-14 21:51:31 UTC
As an additional note, as to why this shouldn't be used for checking if the topic is used by other product's documentation, is that the list only shows content specs that have entities or conditions defined. Any other content specs are all grouped under the "DEFAULT" option.

Comment 3 Lee Newson 2014-02-15 08:18:12 UTC
I ended up requiring having to do this anyway for BZ#1037269.

Added in 1.4-SNAPSHOT build 201402151749

The content spec list is now grouped together into product/version to help identify what content spec you are rendering the topic for. The groups are also sorted alphabetically to make it easier to find your topics.

Note: This version is currently deployed on the development/test server.


Note You need to log in before you can comment on or make changes to this bug.