Bug 1051955 - taskwarrior is built without gnutls-devel
Summary: taskwarrior is built without gnutls-devel
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: task
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Federico Hernandez
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-13 01:12 UTC by Patrick Uiterwijk
Modified: 2014-02-13 01:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-13 01:02:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Patrick Uiterwijk 2014-01-13 01:12:44 UTC
Description of problem:
task cannot use task servers (taskd) as specified on http://taskwarrior.org/projects/taskwarrior/wiki/Server_setup because during build, gnutls-devel is not installed.


Version-Release number of selected component (if applicable):
task-2.3.0-0.1.beta2


How reproducible:
Always


Steps to Reproduce:
1. yum install task
2. task sync


Actual results:
Taskwarrior was built without GnuTLS support.  Sync is not available.


Expected results:
Possibility to setup sync and to sync with taskd.


Additional info:
All that's needed is a BuildRequires: gnutls-devel.
During building, it already says "-- Could NOT find GnuTLS (missing:  GNUTLS_LIBRARY GNUTLS_INCLUDE_DIR) "
(source: http://kojipkgs.fedoraproject.org//packages/task/2.3.0/0.1.beta2.fc19/data/logs/x86_64/build.log)

Comment 1 Fedora Update System 2014-01-13 16:39:07 UTC
task-2.3.0-0.2.beta2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/task-2.3.0-0.2.beta2.fc20

Comment 2 Fedora Update System 2014-01-13 16:39:28 UTC
task-2.3.0-0.2.beta2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/task-2.3.0-0.2.beta2.fc19

Comment 3 Fedora Update System 2014-01-30 03:34:28 UTC
task-2.3.0-0.2.beta2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2014-01-30 03:35:34 UTC
task-2.3.0-0.2.beta2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.