Bug 1052006 - gnome-abrt fails to open
Summary: gnome-abrt fails to open
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-abrt
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1054089
TreeView+ depends on / blocked
 
Reported: 2014-01-13 05:45 UTC by sheepdestroyer
Modified: 2016-12-01 00:46 UTC (History)
3 users (show)

Fixed In Version: gnome-abrt-0.3.5-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1054089 (view as bug list)
Environment:
Last Closed: 2014-01-17 05:48:36 UTC
Type: Bug


Attachments (Terms of Use)

Description sheepdestroyer 2014-01-13 05:45:56 UTC
Description of problem:

trying to launch the bug report tool from activities seems to have no effect, as clicking open in the notification area. The report tools gui does not appear.

typing gnome-abrt in shell does this :

[sheepdestroyer@localhost ~]$gnome-abrt 
ERROR:root:Error opening file: No such file or directory
Traceback (most recent call last):
  File "/usr/bin/gnome-abrt", line 236, in do_activate
    main_window = OopsWindow(self, self.all_sources, controller)
  File "/usr/lib64/python2.7/site-packages/gnome_abrt/views.py", line 326, in __init__
    self._reload_problems(self._source)
  File "/usr/lib64/python2.7/site-packages/gnome_abrt/views.py", line 504, in _reload_problems
    storage_problems.append(problem_to_storage_values(p))
  File "/usr/lib64/python2.7/site-packages/gnome_abrt/views.py", line 91, in problem_to_storage_values
    app = problem.get_application()
  File "/usr/lib64/python2.7/site-packages/gnome_abrt/problems.py", line 242, in get_application
    self['cmdline'])
  File "/usr/lib64/python2.7/site-packages/gnome_abrt/application.py", line 152, in find_application
    stream = dai_icon.load(128, None)
GError: Error opening file: No such file or directory


When trying to launch abrt-gui i get "command not found" even after trying to reinstall it.

[sheepdestroyer@localhost ~]$ abrt-gui
bash: abrt-gui: command not found...



Version-Release number of selected component (if applicable):

Installed Packages
Name        : gnome-abrt
Arch        : x86_64
Version     : 0.3.4
Release     : 1.fc20
Repo        : installed
From repo   : updates

Name        : abrt
Arch        : x86_64
Version     : 2.1.11
Release     : 1.fc20
Repo        : installed
From repo   : updates

Name        : abrt-gui
Arch        : x86_64
Version     : 2.1.11
Release     : 1.fc20
Size        : 240 k
Repo        : installed
From repo   : updates


How reproducible:
every time

Comment 1 Jakub Filak 2014-01-13 15:25:43 UTC
Thank you for the report. abrt-gui has been obsoleted by gnome-abrt.

Upstream commit 2f65da502de49bc06566d9031ea3703d5485f9b6 fixes this bug.

Comment 2 Fedora Update System 2014-01-14 13:13:50 UTC
gnome-abrt-0.3.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gnome-abrt-0.3.5-1.fc20

Comment 3 Fedora Update System 2014-01-15 06:07:23 UTC
Package gnome-abrt-0.3.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-0.3.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0841/gnome-abrt-0.3.5-1.fc20
then log in and leave karma (feedback).

Comment 4 sheepdestroyer 2014-01-16 06:25:56 UTC
Tried the update and problem is solved. Thanks

Comment 5 Fedora Update System 2014-01-17 05:48:36 UTC
gnome-abrt-0.3.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.