Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1052053 - benchmark SPECviewperf12 doesn't work for windows guest
Summary: benchmark SPECviewperf12 doesn't work for windows guest
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Alex Williamson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-13 08:39 UTC by FuXiangChun
Modified: 2014-01-24 04:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-24 04:32:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot-1 (50.87 KB, image/png)
2014-01-13 08:41 UTC, FuXiangChun
no flags Details
gpu information inside guest (34.09 KB, image/png)
2014-01-13 08:42 UTC, FuXiangChun
no flags Details
with gpu (89.14 KB, image/png)
2014-01-14 06:11 UTC, FuXiangChun
no flags Details
without gpu (91.86 KB, image/png)
2014-01-14 06:12 UTC, FuXiangChun
no flags Details

Description FuXiangChun 2014-01-13 08:39:45 UTC
Description of problem:
For windows guest(QE tested win7-64 bit and win2012), SPECviewperf doesn't work inside guest. Root reason is SPECviewperf don't recognize "System Memory". System Memory show 0 Bytes. I added two screenshots to attachment.  Since QE have installed SPECviewperf on physical host(not guest) and don't hit this problem.  

Version-Release number of selected component (if applicable):
3.10.0-64.el7.x86_64
qemu-kvm-1.5.3-30.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1./usr/libexec/qemu-kvm -M pc -cpu SandyBridge -enable-kvm -m 4G -smp 4,sockets=2,cores=2,threads=1,maxcpus=160 -usb -device usb-tablet,id=input0 -name gpu -uuid 990ea161-6b67-47b2-b803-19fb01d30d30 -rtc base=localtime,clock=host,driftfix=slew -drive file=/root/images/win7-64-5.qcow2,if=none,id=drive-virtio-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop -device ide-drive,drive=drive-virtio-disk,id=virtio-disk,bootindex=1 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -k en-us -boot menu=on -serial unix:/tmp/ttyS0,server,nowait -monitor stdio -chardev socket,path=/tmp/qga.sock,server,nowait,id=qga0 -device virtio-serial -device virtserialport,chardev=qga0,name=org.qemu.guest_agent.0,id=sr0 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device rtl8139,netdev=hostnet0,id=virtio-net-pci0,mac=00:01:02:B6:50:23 -spice disable-ticketing,port=5941 -vga qxl -device vfio-pci,host=07:00.0,id=g2

2.run SPECviewperf12 inside guest

3.

Actual results:
see SPECview-screenshot-1.png in attachment

Expected results:


Additional info:
1.For RHEL6.5 guest.  SPECviewperf works well inside guest.

2.Win7-64 bit and win2012 guest have the same problem

Comment 1 FuXiangChun 2014-01-13 08:41:00 UTC
Created attachment 849191 [details]
screenshot-1

Comment 2 FuXiangChun 2014-01-13 08:42:38 UTC
Created attachment 849192 [details]
gpu information inside guest

Comment 4 Alex Williamson 2014-01-13 15:12:02 UTC
Does running it in an guest without an assigned GPU give the same error or different?

Comment 5 FuXiangChun 2014-01-14 06:10:31 UTC
with GPU
SPECviewperf 12 can recognize "Display",Just can not recognize "System Memory" e.g

Display       1024*768*N/Abpp @N/AHz
System Memory 0 Bytes

without GPU
SPECviewperf 12 can not recognize "Display" and "System Memory" 

Display       0*0* N/Abpp @N/AHz
System Memory 0 Bytes

so, My understanding is that SPECviewperf don't support emulated VGA. I added two snapshots(with GPU and without GPU) to attachment.

Comment 6 FuXiangChun 2014-01-14 06:11:21 UTC
Created attachment 849749 [details]
with gpu

Comment 7 FuXiangChun 2014-01-14 06:12:03 UTC
Created attachment 849750 [details]
without gpu

Comment 8 Alex Williamson 2014-01-24 04:32:12 UTC
Proprietary Windows app, can't fix.  SPECviewperf11 works.


Note You need to log in before you can comment on or make changes to this bug.