Bug 1052085 - device_add crashes on non-device driver name
Summary: device_add crashes on non-device driver name
Keywords:
Status: CLOSED DUPLICATE of bug 669524
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Markus Armbruster
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-13 09:52 UTC by Markus Armbruster
Modified: 2014-01-21 09:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-21 09:59:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Markus Armbruster 2014-01-13 09:52:56 UTC
Description of problem:
Monitor device_add with a driver name argument that identifies a
non-device crashes.

How reproducible:
Always

Steps to Reproduce:
1. qemu-kvm -nodefaults -S -display none -monitor stdio
2. device_add rng-egd

Actual results:
Assertion failure
qdev-monitor.c:491:qdev_device_add: Object 0x7f3ee1e74900 is not an instance of type device

Expected results:
The command fails cleanly with an error message such as "'rng-egd' is
not a valid device model name".

Additional info:
Fixed upstream in commit 061e84f.

Comment 2 Markus Armbruster 2014-01-21 09:59:31 UTC
Fix has been folded into the fix for bug 669524.

*** This bug has been marked as a duplicate of bug 669524 ***


Note You need to log in before you can comment on or make changes to this bug.