Bug 1052131 - NPE in server log when creating new rule
Summary: NPE in server log when creating new rule
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ER1
: 6.0.1
Assignee: manstis
QA Contact: Jiri Locker
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-13 11:33 UTC by Jiri Locker
Modified: 2014-08-06 19:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 19:58:34 UTC
Type: Bug


Attachments (Terms of Use)
server.log with NPE (6.81 KB, text/plain)
2014-01-13 11:33 UTC, Jiri Locker
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1055632 0 unspecified CLOSED Incremental build may fail with ConcurrentModificationException 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1055941 0 low CLOSED No facts available after creating new guided rule, NPE in server log 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1073818 0 high CLOSED NPE in server log when creating new rule (#2) 2021-02-22 00:41:40 UTC

Internal Links: 1055632 1055941 1073818

Description Jiri Locker 2014-01-13 11:33:39 UTC
Created attachment 849258 [details]
server.log with NPE

Description of problem:
I am often seeing this exception after running certain automated tests. However it is hard to reproduce manually. After some experimenting, I am convinced it is caused by creating new resource while an incremental build is already running (or has been triggered shortly before creating the new resource). I have revealed two situation when this occurs:

1. creating a new resource (rule) immediately after changing project. This how it happens when I run automated tests. Couldn't reproduce manually.

2. creating new rules quickly in a loop. This the only way I have found to trigger the exception manually. See steps to reproduce.

The exception can only be found in server log. I am unsure if it can affect the Business Central user.

Version-Release number of selected component (if applicable):
ER7

How reproducible:
Hardly. Looks like a synchronization issue.

Steps to Reproduce:
1. select any project
2. keep creating new rules repeatedly. Don't wait after submitting the Create new rule dialog, start creating new rule as soon as the dialog disappears. You have to be quick -- make sure you just hit a few random keys when typing the rule name.

Actual results:
NPE in server log.

Expected results:
It shouldn't happen.

Additional info:

Comment 1 manstis 2014-01-23 10:36:00 UTC
Looking at the log, it does appear that this could be a synchronization issue. I added synchronization to the full and incremental build process for https://bugzilla.redhat.com/show_bug.cgi?id=1055632.

Can you please re-check with your automated tests?

Comment 2 manstis 2014-01-23 11:35:04 UTC
I reproduced. Reopening...

Comment 3 manstis 2014-01-23 15:50:21 UTC
OK, I cannot reproduce with the current master branch following the commit for https://bugzilla.redhat.com/show_bug.cgi?id=1055632 to address the synchronization issues. Putting back to MODIFIED.

Comment #2 related to CR2 (that does not contain the synchronization fix).

Comment 4 Jiri Locker 2014-03-07 09:28:20 UTC
The issue seems to be gone.


Note You need to log in before you can comment on or make changes to this bug.