Bug 1052315 - mount: multiple "size" options when remounting tmpfs
Summary: mount: multiple "size" options when remounting tmpfs
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: util-linux-ng
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Karel Zak
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-13 15:47 UTC by Jakub Jedelsky
Modified: 2014-03-25 10:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-25 10:40:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jakub Jedelsky 2014-01-13 15:47:24 UTC
Description of problem:
When we want to change size of tmpfs mountpoint with remount, the size option is printed out multiply - an old one and new ones - and SELinux options are hidden.

Version-Release number of selected component (if applicable):
RHEL 6.5

How reproducible:
always

Steps to Reproduce:
1. mkdir /mnt/test; mount -t tmpfs -o size=40m none /mnt/test
2. check: mount | grep mnt/test
   # none on /mnt/test type tmpfs (rw,size=40,rootcontext="unconfined_u:object_r:mnt_t:s0")
3. mount -o remount,size=80m /mnt/test
4. check again: mount | grep mnt/test
   # none on /mnt/test type tmpfs (rw,size=40,size=80m)
5. ...continue how many times you want

Actual results:
mount command returns multiply size options and hide selinux options

Expected results:
mount command returns just one and correct size option and all current selinux options

Comment 2 Karel Zak 2014-03-25 10:40:34 UTC
This is mtab problem and recommended solution is to use findmnt(8) or /proc/mounts to get the real info about mountpoints. 

I have doubts we can fix this problem in any sane way for RHEL6. The problem is already fixed in RHEL7.


Note You need to log in before you can comment on or make changes to this bug.