Bug 1052343 - dhclient fails in rawhide pxe boot image with irs_resconf_load failed: 30.
Summary: dhclient fails in rawhide pxe boot image with irs_resconf_load failed: 30.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bind
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tomáš Hozza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1057709 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-13 16:49 UTC by Orion Poplawski
Modified: 2014-01-27 15:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-15 09:51:00 UTC


Attachments (Terms of Use)
patch (3.14 KB, patch)
2014-01-15 08:58 UTC, Jiri Popelka
no flags Details | Diff

Description Orion Poplawski 2014-01-13 16:49:38 UTC
Description of problem:

Trying to boot today's rawhide pxe boot image, dhclient fails to start with:

irs_resconf_load failed: 30.
Can't initialize context: invalid file

Comment 1 Jiri Popelka 2014-01-14 17:09:04 UTC
(In reply to Orion Poplawski from comment #0)
> irs_resconf_load failed: 30.

Means that dhclient couldn't load /etc/resolv.conf.
This code is new in 4.3.0 (rawhide), ATM I have no idea why it failed.

Comment 2 Orion Poplawski 2014-01-14 17:46:17 UTC
Well, there was no /etc/resolv.conf file in the initrd.

Comment 3 Jiri Popelka 2014-01-15 08:58:30 UTC
Created attachment 850391 [details]
patch

I reported this upstream and got a patch.
It fixes irs_resconf_load() from libirs (bind).

Comment 4 Tomáš Hozza 2014-01-15 09:51:00 UTC
Patch applied in bind-9.9.5-0.3.b1.fc21

Comment 5 Ales Kozumplik 2014-01-21 13:02:38 UTC
Still seeing this with Jan-20 rawhide compose.

Comment 6 Jiri Popelka 2014-01-21 13:12:55 UTC
Should be fixed with dhclient-4.3.0-0.4.b1.fc21 (built today).

Comment 7 Jiri Popelka 2014-01-27 09:46:28 UTC
(In reply to Jiri Popelka from comment #6)
> Should be fixed with dhclient-4.3.0-0.4.b1.fc21 (built today).

Actually with dhclient-4.3.0-0.4.b1.fc21 *and* bind-libs-lite-9.9.5-0.4.rc2.fc21

Comment 8 Jiri Popelka 2014-01-27 15:27:40 UTC
*** Bug 1057709 has been marked as a duplicate of this bug. ***

Comment 9 Orion Poplawski 2014-01-27 15:49:43 UTC
Confirmed working with today's rawhide.


Note You need to log in before you can comment on or make changes to this bug.