Bug 1052379 - eclipse crash on autocomplete
Summary: eclipse crash on autocomplete
Keywords:
Status: CLOSED DUPLICATE of bug 1040223
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-13 18:04 UTC by Lev Ufimtsev
Modified: 2014-01-14 06:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-14 06:23:09 UTC
Type: Bug


Attachments (Terms of Use)
Report message (159.49 KB, image/png)
2014-01-13 18:04 UTC, Lev Ufimtsev
no flags Details
Screen shot of when eclipse crashes. (235.87 KB, image/png)
2014-01-13 18:05 UTC, Lev Ufimtsev
no flags Details

Description Lev Ufimtsev 2014-01-13 18:04:44 UTC
Created attachment 849514 [details]
Report message

Description of problem:
 - Eclipse crashes after showing auto-complete suggestions. 

Version-Release number of selected component (if applicable):
 - Fedora 20  (with many software packages installed)   
    -- Chrome is installed and is set to default browser.(Version 31.0.1650.63)

 - Eclipse Kepler   (from 'sudo yum install eclipse' repository) 
    Version: 4.3.1
    Build id: 11fc20

 - Mac book air, 2011.


How reproducible:
 - I can re-produce the problem on each run.

Steps to Reproduce:
 1) Open eclipse. 
 2) Write JAVA code which makes auto-completion pop up.
 3) First few times the auto-completion is ok. After the 4th or 5th time eclipse crashes. 
 4) Eclipse can't be used for more than a few minutes. 

Actual results: 
 - eclipse crashes. 

 - "A problem has been reported" pops up with the following message:
 "A problem in the java-1.7.0-openjdk-headless-1.7.0.60-24.3.0.f20 package has been detected and the diagnostic data has been submitted" 


Expected results:
 - eclipse should hopefully not crash


Additional info:
 * Work around is to edit the (/etc/eclipse.ini) and add the following line

    -Dorg.eclipse.swt.browser.DefaultType=mozilla

  (note, the '-' inclusive) 

  As mentioned here:
  http://stackoverflow.com/questions/16282249/eclipse-4-2-juno-crashes-on-ubuntu-12-04-precise

  This stops eclipse from crashing. 

 * Starting eclipse with '-clean' does not resolve crash 
 * Using a seperate work-space does not resolve the crash. 
 * I have re-installed the operating system, but after the re-install, after some time the problem emerges again.


Please note:
 - This is the first time I'm posting a bug-report on Linux products. I apologize for mistakes in advance. Please correct me on mistakes that I make. 
 - I'm not familiar with diagnostic information that is typically attached with eclipse/Linux bugs (I'm a student at university), please let me know what/how I need to collect for additional diagnostics. 






-------- If eclipse is ran from terminal, the output is as following:
 eclipse
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/eclipse/tycho/core/osgitools/EquinoxResolver.newState
/builddir/build/BUILD/abrt-java-connector-befb850dbc72b117ad6bebabee314e7d41b97183/src/abrt-checker.c:255: can not create output file abrt_checker_25647.log. Disabling logging.
No bp log location saved, using default.
[000:000] Cpu: 6.42.7, x4, 2900Mhz, 3866MB
[000:000] Computer model: Not available
[000:000] Browser XEmbed support present: 1
[000:000] Browser toolkit is Gtk2.
[000:000] Using Gtk2 toolkit
No bp log location saved, using default.
[000:000] Cpu: 6.42.7, x4, 2900Mhz, 3866MB
[000:000] Computer model: Not available

Comment 1 Lev Ufimtsev 2014-01-13 18:05:55 UTC
Created attachment 849515 [details]
Screen shot of when eclipse crashes.

Screen shot of when eclipse crashes.

Comment 2 Roland Grunberg 2014-01-13 21:41:52 UTC
This definitely seems like a webkitgtk issue, given that setting the default web browser for eclipse to something other than webkitgtk works around the problem.

Do you have google-talkplugin installed by any chance ?

Comment 3 Lev Ufimtsev 2014-01-14 00:41:49 UTC
Oh my, very good observation. It was indeed the Google talk plug in.

I now stumbled across:

Common F20 bugs
  - "Eclipse crashes with Google Talk plugin installed"
https://fedoraproject.org/wiki/Common_F20_bugs#Eclipse_crashes_with_Google_Talk_plugin_installed

I guess this submission is a duplicate of:
https://bugzilla.redhat.com/show_bug.cgi?id=1040223

then?

~I hope it get's fixed. 

Thank you

Comment 4 Alexander Kurtakov 2014-01-14 06:23:09 UTC
Closing as duplicate. We are doing our best to fix the problem but there is not much of a promise as google-talkplugin is closed source and this gives us not much chances to know what is it doing. 
Note that the problem happens even with upstream eclipse and we track the problem there too.

*** This bug has been marked as a duplicate of bug 1040223 ***


Note You need to log in before you can comment on or make changes to this bug.